[mythtv-users] LIRC weirdness

Marty Ravell mythtv at rave-tech.com.au
Sun Dec 18 00:31:56 EST 2005

I'm making some progress at long last on getting lirc to work as a receiver
through my PVR-350 and a transmitter on a homebrew serial transmitter to my
Foxtel cable box (STU-120). My channel change script (and the setup itself)
is from lircsetup.com. Box is FC3 from Jarod's guide, front and backend
combined. Everything seems to work pretty cool from the command line. I can
call the chan_change.sh script and my cable box changes channel. This would
tell me that the hardware works fine and that lirc seems to like it's


Problem is that when I run the same script from within MythTV nothing


In following the troubleshooting pages on lircsetup.com I tried the
test_script.sh idea. This works fine from within MythTV. i.e. I get the
output log produced. 


Next test I tried was to put the line which writes the test log entry into
the change_chan.sh script itself.


Weird thing with this is that although the channel is not changed the log
entry line is created.


I know that the script is being run (otherwise the log line would not be
written). Why isn't the irsend part of the script working when called by


Any ideas?








-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20051218/ab8e8898/attachment.htm

More information about the mythtv-users mailing list