[mythtv-users] lirc 0.72 ebuild failing

Preston Crow pc-mythtv05c at crowcastle.net
Tue Dec 6 12:48:32 EST 2005

On Fri, 2005-12-02 at 17:47 -0500, mythtv at jehster.net wrote:
> The newer kenrl (starting with 2.6.13) removed
> some of the classes used in lirc =< 0.7.2. The CVS version worked for me
> and I modified the ebuild to use it. If you're interested you can download
> it from here:
> http://www.jehster.net/gentoo/packages/lirc/lirc-0.8.0_pre1.ebuild
> and followed the directions here to install it:
> http://gentoo-wiki.com/HOWTO_Installing_3rd_Party_Ebuilds
> You'll also have to unmask it by adding "=app-misc/lirc-0.8.0_pre1 ~x86" to
> /etc/portage/package.keywords and emerged it as normal.

Your ebuild gave me modules that load, but I'm
missing /etc/init.d/lircd.  I fixed that with:

# cd /usr/local/portage/app-misc/lirc
# mkdir files
# cp -p /usr/portage/app-misc/lirc/files/lirc[a-z]* files/
# ebuild lirc-0.8.0_pre1.ebuild digest
# emerge lirc

So the ebuild is fine, it just requires files that are in the regular
portage tree to be copied into the overlay tree.  Now everything seems
to be fine, though I'm not in front of the machine, so I can't test the


More information about the mythtv-users mailing list