[mythtv-users] lirc 0.72 ebuild failing

mythtv at jehster.net mythtv at jehster.net
Fri Dec 2 17:47:15 EST 2005

Travis Osterman wrote:
> I am getting the following error when trying to emerge lirc (undefined
> I2C_ALGO_BIT).  Googling hasn't gotten me any leads, if you have any
> ideas, they would be appreciated.  Thank you.
> -- Travis


I had the same problem. The newer kenrl (starting with 2.6.13) removed
some of the classes used in lirc =< 0.7.2. The CVS version worked for me
and I modified the ebuild to use it. If you're interested you can download
it from here:


and followed the directions here to install it:


You'll also have to unmask it by adding "=app-misc/lirc-0.8.0_pre1 ~x86" to
/etc/portage/package.keywords and emerged it as normal.

Hope it helps,

More information about the mythtv-users mailing list