[mythtv-users] various mythweb manual scheduling bugs in 1.18.1

f-myth-users at media.mit.edu f-myth-users at media.mit.edu
Thu Dec 1 21:27:22 EST 2005

In mythtv 1.18.1, using mythweb:

Trying to schedule a manual recording is...  peculiar.  I've done some
searching but haven't been able to unearth any reports about this, but
perhaps I'm just looking in the wrong place.

If I click on "Manually Schedule", adjust the start time to be a
minute or two in the future, adjust the length to 2 minutes, and click
Create Schedule, it pops up a slightly different menu that says Save
Schedule at the bottom.  Nothing has actually been scheduled yet,
though, according to the Scheduled Recordings page on my frontend,
or in the same page in mythweb.  And clicking on Save Schedule is a
no-op; I just get the same page back, over and over and over.

HOWEVER, if I instead click in the Schedule Override section for
"Record this specific showing", it then puts me back in what looks
like first menu again (fewer options), but with Save Schedule still at
the bottom.  Clicking "Save Schedule" still doesn't cause the schedule
to be created.

If I then -undo- that override by clicking on "Schedule normally',
THEN the Save Schedule button actually schedules the recording.  I
just repeated this about 5 times in a row to convince myself that this
was what was really happening.

Even weirder, if I don't touch the start time or the length, THEN the
Save Schedule button pops up the second page (with Create Schedule),
BUT it's already been scheduled before I can even edit that page, and
so the recording starts instantly---the FE, mythweb, and the tuner
status all say a recording is going on.  So apparently things are
different if the recording starts this instant vs if it starts a few
minutes in the future.  [-Or- it's the length part, but see below for
why I'm giving up on debugging this further right now.]

Furthermore, while trying to debug this, I now have a recording in the
Scheduled Recordings page in my FE that's -in the past- and yet claims
to be recording, and is unkillable---I can't make it go away from that
page (even though no tuner is currently recording).  It's definitely
red (like a recording that's actually recording) even though its start
and end time are several minutes in the past.  I haven't tried all the
other possibilities in the mythweb UI because I'd like to at least
figure out how to undo whatever it did just now, and to find out if
this behavior might be fixed in SVN or if it's just rare that people
schedule manual recordings.  (Or if there's some bug having to do with
specifying its length or start-time.)

How is this menu -supposed- to work?

[And should I just avoid manual scheduling in mythweb in 1.18.1?]


P.S.  "Delete" in the Scheduled Recordings page in mythweb didn't do
at all what I expected---it set an override saying "don't record this
manual recording" instead of just deleting it outright, as the similar
command in the FE would do.  If I schedule something and change my
mind, how do I get mythweb to just -forget- about it and not mark it
as a scheduled recording that's been overridden not to happen?  Are
mythfrontend and mythweb supposed to be incompatible in this way?

P.P.S.  Rebooting the backend made the phantom recording at 20:47
finally vanish.  However, it -then- instantly started recording
another manual recording, claimed to start at 20:44, and which was
-not- in the display before I rebooted.  Using "Stop Recording" in
mythfrontend actually got it to stop, and its color has now changed
from red to gray and it's marked S there (and the tuner is marked "not
recording").  [It's still hanging around, gray, in my Scheduled
Recordings menu in the FE, though, even though it's now been about 15
minutes since the recording stopped; apparently that's because it was
one of the default-2-hour recordings from mythweb, because it claims
to have recorded from 21:03 to 22:44 (even though it's only 21:18 here
at the moment; I'm guessing that I stopped it at 22:44, but those
times still don't make lots of sense to me).  I'm hoping it will
finally vanish from the Scheduled Recordings page on the FE sometime
after 22:44.  It's -really- confusing---the actual one-liner at the
top of my FE's screen says "21:03", then the channel ID, then "Thu Dec 1
20:44:00", but the details display in the bottom half of the screen
claims "21:03 - 22:44" (there's -no way- I set those times myself, and
they don't correspond well to when I booted/cancelled anything), even
though the line right underneath -that- also claims 20:44:00 just like
the highlighted line at the top.  WTF?]

More information about the mythtv-users mailing list