[mythtv-users] Any Fedora Core 3 nuvexport RPMs out there?

Azmat azmat.hussain at gmail.com
Tue Aug 30 14:24:46 UTC 2005


I've tried this, but apt still can't find lve:

# apt-get install lve
Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package lve

I've also tried to compile lve manually. I relinked ffmpeg to the source I 
downloaded from their CVS and ran "make". Though I ran into the following 
compilation errors:
g++ -O1 -g -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I../mpeg2dec/include/ 
-I../ffmpeg/libavcodec/ -c -o frame_srv.o frame_srv.c
In file included from ../ffmpeg/libavcodec/liba52/a52.h:27,
from frame_srv.c:32:
../ffmpeg/libavcodec/liba52/../avcodec.h:14:20: avutil.h: No such file or 
directory
In file included from ../ffmpeg/libavcodec/liba52/a52.h:27,
from frame_srv.c:32:
../ffmpeg/libavcodec/liba52/../avcodec.h:743: error: `AVRational' does not 
name a type
../ffmpeg/libavcodec/liba52/../avcodec.h:1274: error: `AVRational' does not 
name a type
../ffmpeg/libavcodec/liba52/../avcodec.h:1896: error: ISO C++ forbids 
declaration of `AVRational' with no type
../ffmpeg/libavcodec/liba52/../avcodec.h:1896: error: expected `;' before 
'*' token
make[1]: *** [frame_srv.o] Error 1
make[1]: Leaving directory `/home/mythtv/Desktop/lve/src'
make: *** [all-recursive] Error 2

I suspect something went wrong earlier in the stream but haven't had time to 
work through this. I'd rather just grab it from apt and be done with it, if 
possible. Anyone have any advice?

Thanks,

Azmat

On 6/17/05, Fedor Pikus <fpikus at gmail.com> wrote:
> 
> On 6/17/05, Chris Petersen <lists at forevermore.net> wrote:
> > > I've failed utterly to build one of the [seemingly many] deps. for
> > > nuvexport (can't remember off the top of my head; the one with the
> > > built-in ffmpeg dep.) on my FC3 box. The package in question has
> > > compilation errors (which I've fixed) and off ffmpeg link errors 
> (which
> > > have confounded me).
> >
> > I build RPM's for nuvexport and put them right on the site along with
> > the rest of the downloads:
> >
> > http://forevermore.net/files/nuvexport/
> >
> > How can you have compile problems? nuvexport doesn't get compiled. You
> > could also just do:
> >
> > rpmbuild -tb nuvexport-0.2-0.20050605.cvs.tar.bz2
> >
> > Anyway, you'll get a package requirement for "lve" -- this doesn't
> > compile in fc3, so you're stuck without the ability to run mpeg2cut (you
> > can install the nuvexport rpm safely with --nodeps if that's the only
> > problem you see)
> >
> > -Chris
> 
> Or add Dag's repo to apt's sources-list, temporarily:
> rpm http://apt.sw.be/ redhat/el3/en/i386 dag
> rpm http://apt.sw.be/ fedora/3/en/i386 dag
> 
> Then apt-get install lve gets you this version: lve-0.040322-1.1.el3.rf
> 
> You can comment out Dag's lines after you're done.
> --
> Fedor G Pikus (fpikus at gmail.com)
> http://www.pikus.net
> http://wild-light.com
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> 



-- 


Azmat
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20050830/39a4a6d9/attachment.htm


More information about the mythtv-users mailing list