[mythtv-users] problems building projectx

Paul Barker myth at sixtimesnine.net
Thu Aug 25 15:46:13 UTC 2005

> # ./build.sh
> bash: ./build.sh: /bin/bash^M: bad interpreter: No such file or directory
> /bin/bash is the correct path, I've also tried changing the first line to
> !#bin/sh , which I know works in other scripts, I get a similar error
> using
> this.

Look closely at the shebang line and you'll see a ^M - that's DOS /
Windows CR character (CTL M). My advice would be run build.sh through

> Running the individual lines of the script goes ok, but I'm getting this:
> # javac -encoding "ISO-8859-1" -O -g:none -classpath
> lib/commons-net-1.3.0.jar:lib/jakarta-oro-2.0.8.jar
> -d build @sources.lst
> src/net/sourceforge/dvb/projectx/audio/Audio.java:34: error while writing
> net.sourceforge.dvb.projectx.audio.Audio:
> build/net/sourceforge/dvb/projectx/audio/Audio.class
> (No such file or directory)
> public class Audio
>        ^

I had the exact same error using the SUN JSDK. I think what fixed it for
me was setting the JAVA_HOME and CLASSPATH environment variables
correctly. Look in either install.sh or install.bat (yes I know thats for
DOS) files for clues as how to set it as I'm not sure where the version of
Java you're using keeps things.

I have successfully built ProjectX on Fedora using the SUN JSDK 1.5.x. If
you hunt around on the web there is a prebuilt JAR file. If I bookmarked
the link I'll try and post it later tonight.

BTW - Apologies if this turns up twice. Forgot to switch to my myth
identity before sending :(


More information about the mythtv-users mailing list