[mythtv-users] RE: Fusion HDTV DVB-T Plus card and Fedora Core 4??

Buzz buzz at oska.com
Thu Aug 25 02:06:39 UTC 2005

(cc'd to mythtv-users for other FusionHTDV DVB-T Plus or Fedora Core 4

Thanks for your email (and sorry for the delay getting back to you), it was
really helpful (especially to see the expected dmesg output), and I now have
a "working but unstable"  setup of FC4+FusionHDTV DVB-T Plus. 

Aparently I had confused the entire install system by having both RPM based
installs and compiled installs installed at the same time (even though I did
a 'make uninstall' of the compiled one and a 'rpm -I --force xxx.rpm' to
re-install the Atrpms version/s....

....so a re-install of FC4 and mythtv from Atrpms seemed to help, although
it was still kinda long-and-complicated to install.

I didn't need to put the "options cx88xx card=21" in my modprobe.conf,
infact, I did put it in there and it seemed to stop the card from working,
so I took it out again.

I still haven't even tried lirc, more worried about a stable /usable/ system
first that's "family-proof".

The channel setup process "scan" that's supposed to 'autodetect' the
channels seems to NOT work at all with this new install (from Atrpms), but
in the previous install, at a time that I had it briefly working (probably
from the SVN sources),  it did work.    Instead, to get it to work now, I
had to do the 'advanced' setup, enter a "transport" for each channel
frequency that's being broadcast here in Brisbane, and set the width(I
forget what it was called) to 7Mhz.    The I could do a "scan of all
existing transports only", and the channels all appeared.  I got that idea
from following someone else who had the same problem on a mythtv forum on
the web somewhere.   Weird huh. 

I've also found that mythfrontend crashes/segfaults if I change the channel
to many times on live TV (under 10 times usually).  It also keeps throwing
"file not found" errors in /var/lib/mythtv/  (which is where I told it to
record to, and has a 'chmod 777' on it to be sure it's not permissions. )

Oh, and I'm also not entirely sure that it's actually recording stuff.
I've scheduled a few things today, so I'll get home from work and check it
tonite.   :-)

It seems to me like it's all WAY to complicated to setup, and I'm a
certified RHCE (RedHat Certified Engineer) and sysadmin Linux for a living.
:-)   It needs to be made simpler, and more "intuitive" to install.     Once
installed, the front-end is pretty impressive though.   :-)

My install process went something like this ( I kept a more detailed log of
exact commands, but it's at home) :
1)install FC4 "complete install" - probably over-kill, but I have a big
disk, and I didn't want to miss anything important.
2)yum update
3)yum update kernel
4)reboot to new kernel
4.5) remove old kernel/s if you want, start with: rpm -qa | grep '2.6.11' 
5)config yum.conf for Atrpms
6)yum install mythtv-suite
7) setup tv_grab_au (NMSN version)
8) setup mysql, and setup mythconverg database (mc.sql)
9) mythbackend (for schema upgrade)
10) mythtv-setup
11) mythfilldatabase
11) mythbackend & 
12) mythfrontend [-v channel|all]
13) while not working,goto step 10, repeat 10->12 till working, fiddling
with semi-random settings.

How's your install going?

David B.

-----Original Message-----
From: Andrew Speer [mailto:andrew.speer at isolutions.com.au] 
Sent: Monday, 22 August 2005 3:06 AM
To: buzz at oska.com
Subject: Re: Fusion HDTV DVB-T Plus card and Fedora Core 4??

Just saw your post on the MythTV list via Gossamer Threads (the archives). I
am replying to you via email because I am not a list member.

I have only just finished setting up (ie tonight !) an FC4 box with the
Fusion HDTV DVB-T Plus card, which has been OK for me. Not sure where you
are, but I am in Australia, so all below applies to the version of the card
shipped here.

I cannot comment on the segfaulting of your subversion checkout of myth, but
there was one large discrepancy in your email vs what I have seen:

I am using the atrpms install of MythTV, and have found that DVB support
*is* compiled in. I was bracing myself for a long round of
download/compile/test cycles, but was pleasantly surprised when it all
worked "out the box".

I am running kernel 2.6.12-1.1398_FC4

The dmesg output at boot:

Linux video capture interface: v1.00
cx2388x dvb driver version 0.0.4 loaded
cx88[0]: subsystem: 18ac:db11, board: DVICO FusionHDTV DVB-T Plus
[card=21,insmod option]
ACPI: PCI Interrupt 0000:00:0a.2[A] -> Link [LNKC] -> GSI 10 (level, low) ->
IRQ 10
cx88[0]/2: found at 0000:00:0a.2, rev: 5, irq: 10, latency: 32, mmio: 
cx88[0]/2: cx2388x based dvb card
DVB: registering new adapter (cx88[0]).
DVB: registering frontend 0 (DVICO FusionHDTV DVB-T Plus)...
cx2388x v4l2 driver version 0.0.4 loaded
ACPI: PCI Interrupt 0000:00:0a.0[A] -> Link [LNKC] -> GSI 10 (level, low) ->
IRQ 10
cx88[0]/0: found at 0000:00:0a.0, rev: 5, irq: 10, latency: 32, mmio: 
cx88[0]/0: registered device video0 [v4l2]
cx88[0]/0: registered device vbi0

To get this I had to use the following modprobe.conf option:

options cx88xx card=21

And that was about it. Ran mythtvsetup, selected a DVB card as the type of
capture card and I was away.

The only compilation I have had to do is to lirc, to hack it to work with
the DVICO remote I got with the card. The drivers that came with lirc (even
lirc 0.7.2, which is supposed to support the remote) did not work with the
model I was shipped with, which looks like this:


If you eventually do get myth working, but can't get the remote working let
me know and I will try to help ..

Good luck,

Andrew Speer

More information about the mythtv-users mailing list