[mythtv-users] ALSA Digital output

Phill Edwards philledwards at gmail.com
Wed Aug 24 13:26:17 UTC 2005

> >I want to use digital output on my soundcard. The card have both an
> >optical and coax connection the card is a Intel 80801EB/ER ICH5 AC97.
> >
> >So this is what I've done so far. Checked out alsamixer and found settings
> >that seem interesting IEC958 and IEC958 Playback. IEC958 can't be changed
> >in any way neither can the level be changed nor can it be muted. IEC958
> >Playback level can be changed at 4 specific positions 0, 33, 66 and 100%.
> >This all I can find in alsamixer that has to do with digital output. I've
> >connected both the optical and the coax outputs to the corresponing inputs
> >on my amplifier and it detects NO digital signal. So I downloaded a lot of
> >different mixer to see if anything made me lucky. In a mixer called
> >opmixer there is a setting called dig1, if I unmute this on I get PCM
> >48kHz detected on my amplifier but it doesn't seem stable since my amp
> >loses it for short moments every now and then.
> >
> >After digging thru some material I found that sound have to be directed
> >directly for digital output via a specific hardware option in i.e. mplayer.
> >
> >mplayer -ao alsa:device=hw=0.0 is the correct setting for analog output
> >mplayer -ao alsa:device=hw=0.3 should be the correct setting for digital
> >output
> >
> >Well I get no sound what so ever when using the digital output options in
> >mplayer even though me amp has detected a digital signal.

A lot of  people including myself have had success by following the
instructions at http://www.mythtv.info/moin.cgi/DigitalSoundHowTo

After following his setup and making the .asoundrc right for my card I
went into the MythTV settings and set the Audio Output device to


More information about the mythtv-users mailing list