[mythtv-users] NOVA-T Hauppauge testing to see if my card is working

David myth at dgreaves.com
Mon Aug 22 20:30:22 UTC 2005

Stephen Kitchener wrote:

>I would like to able to see if my card is working before I get into the full 
>mythtv install process, so I tried to install the modules as described in 
>various howto's and documents that I have found, but I have not been able to 
>get the frontend installed or get the device entries added to /dev/ or /udev 
>as Ithink my machine has. I am running Mandrake 10.1 and I think that it is 
>udev, someone will correct me I am sure..
I had to:
cd /dev
(and FWIW, on Debian IIRC it didn't work properly - I think I had to
manually create the /dev/dvb/ dir - maybe just my system)

>Anyway her is what I have done,
>I found on one document that I needed to have dvb-ttpci-01.fw installed 
>in /usr/lib/hotplug/firmware  and another site said that I needed to have
>dvb-fe-tda10045.fw and yet another said that I needed tda1004x.mc, so I am a 
>little confused as to what I need to have in  /usr/lib/hotplug/firmware.
teak:/# ll /usr/lib/hotplug/firmware/
-rw-r--r--  1 root root 30555 2005-08-11 18:34 dvb-fe-tda10045.fw

>However, when I run these commands as described on 
>modprobe v4l1-compat
>modprobe v4l2-common
>modprobe video-buf
>modprobe dvb-core
>modprobe tda1004x
>modprobe saa7146
>modprobe saa7146_vv
>modprobe ttpci-eeprom
>modprobe budget
>modprobe budget-ci
I am using

Here are my modules:

Module                  Size  Used by
budget_ci              11520  7
tda1004x               14724  1 budget_ci
firmware_class          7936  1 budget_ci
budget_core             7428  1 budget_ci
dvb_core               76072  2 budget_ci,budget_core
saa7146                15240  2 budget_ci,budget_core
ttpci_eeprom            2432  1 budget_core
stv0299                10888  1 budget_ci

I just modprobe budget_ci and it brings the rest in.

I don't have saa7146_vv - try and get rid of that...

I put some notes on the kernel config here:

please verify... :)

>and look in dmesg for the results, I get half the answer expected, ie 
>saa7146: register extension 'budget dvb'.
>PCI: Found IRQ 3 for device 0000:00:0b.0
>PCI: Sharing IRQ 3 with 0000:00:0c.0
>saa7146: found saa7146 @ mem f8bde000 (revision 1, irq 3) (0x13c2,0x1005).
>DVB: registering new adapter (TT-Budget/WinTV-NOVA-T  PCI).
>TT-Budget/WinTV-NOVA-T  PCI adapter 0 has MAC addr = 00:d0:5c:21:82:cd
>However I don't get the line saying that the front end was installed or 
>What  can I do to rectify this please ?? Am I missing modules that I need to 
>install ??
>I am running Mandrake 10.1 with a 2.6 kernel and I am using a Hauppauge Nova-t 
>card that "lspci -v" gives as a result this..
>00:0b.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
>        Subsystem: Technotrend Systemtechnik GmbH Technotrend-Budget / 
>Hauppauge WinTV-NOVA-T DVB card
>        Flags: bus master, medium devsel, latency 32, IRQ 3
>        Memory at ed800000 (32-bit, non-prefetchable) [size=512]
>I have tried to run kaffine, I realise that this isn't a kaffine list but at 
>least it will give me an idication of the card working or not. I reports that 
>if can't find the dev device, is that because the front-end isn't being 
>initialised ??
I suspect so.
I found Kaffiene to be excellent to get things going :)


More information about the mythtv-users mailing list