[mythtv-users] re DirectTV external tuner help

Alex Van Deusen alex.vandeusen at gmail.com
Sun Aug 21 03:42:59 UTC 2005

Alex Van Deusen wrote: 

>I have a Sony Bat55 directv box. It is connected via a serial cable to 
>my mythbackend. The ports are enabled in bios. 
>I downloaded the script from tarek "sony.pl". Then put it into 
>/usr/local/sony.pl. In mythtv-setup I set the command to reference 
>that location. 
>I tried to to have myth record and change channels but it did not work. 
What does did not work mean? Did you get an error? What happens when 
you try the script from the command line. Does the serial port in the 
script match the one you have the receiver connected to? By default the 
script uses /dev/ttyS0. 

>I then logged in as root su, when I did setserial dev/ttyS0 it gave me 
>correct information and listed irq4, dev/ttyS1 is irq3 
>It seems like it is a problem with the user not having access, but I 
>dont know how to troubleshoot. 
Probably not, as you set the devices to 777. There are so many other 
things it could be like: cable is wired wrong, script is not the right 
one for that receiver, is the script set to the same device you have the 
directv receiver plugged into. BTW, on some (most?) Linux distros the 
dev entries are created dynamically and the permissions may be reset 
after a reboot. So don't reboot (this isn't Winblows after all). 

>One note I am sharing IRQ's, I have 5 capture cards in the box, and 
>scsi, agp, etc.. 
In this case shouldn't be a problem. 

I have a different receiver (RCA DRD-435) and use a different script 
(rca_control.pl), but this link may help you: 


mythtv-users mailing list 
mythtv-users at mythtv.org 

All I used the windows program to test if the serial cable and sat b55
box are working properly.  No issues changing channels works fine.  I
went into bios and set the serial ports to use irq 4, irq 3 and then
reserved IRQ 3 and IRQ4.

I tried the Sony0.pl script but I get an error message when trying to
run it from command prompt "bad interpreter: no such file or

When I try to run the original sony.pl  I get an error (0x00)

Any help would be greatly appreciated.

More information about the mythtv-users mailing list