[mythtv-users] tv_grab_au problems + segfault

Jeff Mills hybiepoo at hotmail.com
Sun Aug 14 07:53:48 UTC 2005

Hi all,
I've got a few issues that I havent been able to work out over the last few 
Firstly, I have tested my TV Card using tvtime, and I am able to change 
channels and hear sound fine, so I'm assuming my card and tuner have been 
detected properly.

My first problem is that I havent been able to get any program info into 
I have tried the tv_grab_au (0.6.2) file that connects to the d1.com.au 
database, and it gives me an empty EPG. When I move along the timeslots, 
things are fine, but if I attempt to move up or down between (empty) 
channels, mythtv segfaults. This may be normal if the EPG is empty. I'm not 
This script seems to add all of the channels I'm requesting as I can see 
them in the mythsetup channel editing section after running 
mythfilldatabase. After running mythfilldatabase, I see 4523 programs 
If I go into the Scheduling section, again the EPG is empty, but if I search 
by channel I am given channel numbers, I can choose a channel, and I can 
view all the programs under that channel.
When I try to watch live tv, I am unable to change channels. Would this be 
because the EPG is screwed? I thought I might still be able to change 
channels without the EPG seeing as the channels are actually shown in the 
channel configuration under mythsetup.

I have not really been able to get the immir.com script working at all.
Does this script also fill the channels automatically like the d1 version?
When I run mythfilldatabase (after running mythsetup and going through the 
config) I am given errors "Unable to find table for pid=xxxxxxxx, 
If I go to the url manually, sure enough, its a blank page.

Sorry about the long winded mail.
Any help is appreciated.


Speak when you are angry--and you will make the best speech you'll ever 
Laurence J. Peter (1919 - 1988)

More information about the mythtv-users mailing list