[mythtv-users] [OT] Xbox Frontend/Xebian 1.1/Alsa

CTD ctd at minneapolish3.com
Fri Aug 5 01:53:26 UTC 2005

Dave wrote:

>On 8/4/05, Johan Kihlström <johan.kihlstrom at bredband.net> wrote:
>>Michael T. Dean wrote:
>>>Dave wrote:
>>>>    I had a frontend on my Xbox without issue for about 8 months.
>>>>Then I
>>>>decided to upgrade Myth to .18, and in the process, upgrade Xebian to
>>>>    Problem is, now I can't get sound of the XBox with Myth.  I can play
>>>>audio OK using aplay, but when I go to view a recording with Myth I
>>>>get  "mixer unable to find control PCM"
>>>What happens when you set "Mixer Controls" to "Master" instead of "PCM"?
>>>mythtv-users mailing list
>>>mythtv-users at mythtv.org
>>Doesn't matter, I'm afraid
>>I just had the same problem when upgrading to the latest Xebian.
>>The sound device in the X-box has no mixer, so in order to make ALSA
>>work you have to disable internal mixing in myth.
>>You also need a good .asoundrc and instead of selecting /dev/dsp in
>>audio you have to write ALSA:(device from asoundrc)
>>Good luck!
>>mythtv-users mailing list
>>mythtv-users at mythtv.org
>Ok, disabling the internal mixed fixed it.  I swear I tried this
>yesterday after reading about the XBox not having a hardware
>Anyway, I've got sound with: MixerControl=PCM (this is probably
>ignored since internal mixing is off), AudioDevice and
>Thanks for the help & suggestions!
>mythtv-users mailing list
>mythtv-users at mythtv.org
I basically had the same issue.  I installed  myth 0.18.1 using install 
help from http://bit.blkbk.com/ (0.4.5-beta) on a xebian 1.1.0 xbox.  I 
followed a previous post's instructions where the only change I had to 
make was setting Audio Output Device to /dev/dsp.  No volume control in 
mythtv, but I have sound.

Concerning some of the posts about HW vs. SW mod.  I found the info on 
www.xbox-linux.org a little dated in regards to the SW mod 
instructions.  I actually bought a mod chip after unsuccessfully 
attempting a SW mod using the www.xbox-linux.org instructions.  By the 
time my mod chip arrived, I found other more up to date instructions to 
accomplish the SW mod on almost any xbox no matter what HW version or 
Dashboard version.

I basically followed the instructions on the following links to SW-mod 
the xbox:

I did purchase the an action replay kit from ebay for $20 and rented the 
ORIGINAL MechAssault Game in order to perform the SW mod.

I then followed the http://bit.blkbk.com/ instructions.

Then I used some evolutions dashboard tutorial instructions on 
xbox-scene.com on how to start the linux install w/o needing the boot CD.

Now I have a stable and cheap  frontend.

Hope that helps.

More information about the mythtv-users mailing list