[mythtv-users] Re: OT: LIRC on Debian with a custom 2.6.8 kernel

Ciaran ciaranj at gmail.com
Tue Sep 28 02:32:09 EDT 2004

I'm trying to get lirc working on my system at the minute (Debian 3.1,
2.6.8-1)  and I've compiled both pre4 and pre7, when I run up  lircd I
use 'lircd --use-device=/dev/input/event0' as recommended, but as soon
as I start myth up the keyboard becomes completely unresponsive :(.

If I run 'irw' (no parameters passed) the screen scrolls up with no
visible output, regardless of whether I use my remote or not.

Now, I'm using a nova-t pci card (the new style) so its possibly a
driver issue, but hopefully someone else has experienced theses
problems in the past and knows the solution?

- Hopefully ;)
- Ciaran

On Mon, 27 Sep 2004 21:42:24 -0700 (MST), Shawn Asmussen
<asmussen at cox.net> wrote:
> > Anyone? Someone out there must be running a 2.6 kernel with an lirc
> > module? Even if it was a serial port module... how did you get it to
> > compile?
> > -Chris
> >
> >
> > On Sun, 26 Sep 2004 19:37:27 -0400, Christopher Flynn
> > <flynnguy at gmail.com> wrote:
> >> I have an ahanix D5 case with lcd and IR on the parallel port. I have
> >> the lcd working through lcdproc and now I'm trying to compile the lirc
> >> module for my kernel. However, when I do I get:
> >> make[2]: Entering directory `/usr/src/modules/lirc/drivers/lirc_i2c'
> >> Makefile:359: /usr/src/linux//Rules.make: No such file or directory
> >> make[2]: *** No rule to make target `/usr/src/linux//Rules.make'.  Stop.
> >> make[2]: Leaving directory `/usr/src/modules/lirc/drivers/lirc_i2c'
> >> make[1]: *** [all-recursive] Error 1
> >> make[1]: Leaving directory `/usr/src/modules/lirc/drivers'
> >> make: *** [i2c] Error 2
> >>
> >> From what I can tell (from searching) it is looking for Rules.make but
> >> that is not available in 2.6 correct? Once I get it compiled I can
> >> play with the parallel port settings and hopefully get them to work.
> >>
> I think you just need to use a newer version of the lirc code. Something
> changed at some point with the 2.6 kernel that required them to make a few
> changes to the lirc code to make it work. I had the same problem the first
> time I tried to compile the lirc tarball that I had with 2.6.8, and I
> found out that I needed to upgrade to one of the latest cvs snapshots. I'm
> currently using the 0.7.0pre7 version, and that will compile with 2.6.8.
> As a side note, although I got it compiled with 2.6.8-1, I found that when
> I tested it, lircd core dumped every time that I tried to test it with
> irw. Could be an issue with the lirc code, or maybe the ivtv driver, since
> the lirc driver has to interact somehow with the ivtv driver to use the
> hauppauge remote. I went back to the 2.6.5 kernel that FC2 shipped with,
> and lirc worked fine, so whatever the problem was, it seemed to only show
> up with the 2.6.8 kernel. The problem I saw might have been only with the
> hauppauge lirc driver, or with a specific version or versions of the ivtv
> driver, or maybe in the kernel itself. All I know for sure is that going
> back down to 2.6.5 made my problem disappear.
> Shawn Asmussen
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

- Ciaran
http://www.wombatinvasion.com/ (Share the love)

More information about the mythtv-users mailing list