[mythtv-users] Re: anyone attempt mythfrontend on Cygwin?

Joel Anderson bitjunkie at gmail.com
Mon Sep 27 14:12:27 EDT 2004

> Well I have moved beyond the problems of Dialog Box issues.  I broke
> it down to the fact that qnetwork.h exists both for DirectX and for
> QT.  Knowing this - I knew that my earlier workaround in libmyth would
> not be functional in libmythtv.
> so, in mythcontext.h and .cpp
> #if defined(USING_DIRECTX)
> #include </opt/qt/3.2/qt-x11-free-3.2.3/include/qnetwork.h>
> #endif
> #if !defined(USING_DIRECTX)
> #include <qtnetwork.h>
> #endif
> instead of just including qnetwork.h .

Wow, you're way ahead of me now, at least with directx enabled.

> This also means - ignore what was said on the dev list about including
> windows.h and initguid.h in qnetwork.h for directx.  That will lead to
> more trouble than it is worth.

I missed this anyway, so a good mistake I guess.  ;)

> Coming back around, libmyth will compile without a hitch (provided you
> have made appropriate changes to mythmediamonitor and libmyth.pro)

Ok, I missed something else then too.  What changes need to be made for these?

> Libmythtv now decides to hiccup in a little more unfortunate a place:
> $ make
> g++ -c -pipe -fdata-sections -Wall -W -O3 -march=pentiumpro
> -fomit-frame-pointer `freetype-config --cflags` -D_REENTRANT
> -I/opt/qt/3.2/qt-x11-free-3.2.3/mkspecs/default -I.
> -I/usr/local/include -I../libmyth -I.. -Idvbdev -I../libavcodec
> -I/usr/include/directx -I/opt/qt/3.2/qt-x11-free-3.2.3/include -o
> vsync.o vsync.cpp
> vsync.cpp: In function `int drmWaitVBlank(int, drm_wait_vblank_t*)':
> vsync.cpp:211: error: parse error before `)' token
> vsync.cpp:211: error: `_IOWR' undeclared (first use this function)
> vsync.cpp:211: error: (Each undeclared identifier is reported only once for
>   each function it appears in.)
> make: *** [vsync.o] Error 1
> It seems that /usr/include/asm/ioctl.h doesn't exist, which is where
> _IOWR is declared I believe.  I will be out of town for the weekend
> and unable to work more with this, but still moving forward...

This is the same error I hit the first time through, on 0.15.1 with no
directx.  I'm still not quite there again with directx turned on.  I
switched over to working with 0.16 now to try to get to the same page
that you're on.  Am I correct that you're building from 0.16, or from


More information about the mythtv-users mailing list