[mythtv-users] mythmusic and ALSA/SPDIF question - SPDIF working for everything but mythmusic

Vinton Coffman vintonc at redzone.com
Fri Sep 24 10:55:00 EDT 2004

I have ALSA output through the SPDIF working with live tv and recorded 
by following the HOWTO on mythtv.info and using the second, 
comprehensive .asoundrc file on that site.  I changed mythtv's audio 
device to "ALSA:mixed-digital" per the HOWTO and mythvideo to "-ao 
alsa9:mixed-digital".  Both work well.  I can run aplay and get other 
sounds to play while watching live tv, so there doesn't seem to be any 
blocking going on.

I noticed some minor popping the other night but my myth box is Athlon 
2500 and it was recording with both pvr-250's, flaggingcomms (low cpu 
setting) and I was watching a previously recorded show.  The popping 
started when I skipped backward but went away by exiting and opening 
the show again.  Not worried about that, a faster cpu would probably 
fix that.

The problem is I can't find a usable device for mythmusic.  No matter 
what I put in Setup->Media->music->general audio device, I get this 
error "AudioOutput: timed-out opening 'ALSA:mixed-digital'."  The AC3 
pass thru is off too.  This was the only solution I could find in the 
archive, but I didn't have it set to start with.

Does anyone have SPDIF output working with mythmusic?  What device did 
you use?  Is the the same as mythvideo or mythtv?


nForce2 based motherboard
mythtv 0.16
alsa cvs (one month old)

More information about the mythtv-users mailing list