[mythtv-users] Remote Control Setup

1canuck2 1canuck2 at sympatico.ca
Sat Sep 18 22:05:45 EDT 2004

Have you configured or downloaded the correct .lircrc and lircd.conf file 
(and put them in the correct location, and restard lircd)?

You can download the ones for the Hauppage remote from Jarod's site. Without 
these, irw will show nothing as it does not know how to interpret the input 
it receives. It took me a little while to grasp lirc, and I am still no 
expert. But basically, as I understand it (in simple terms), one file tells 
lirc which remote commands to expect and one file tells it which mythtv 
command to interpet the input to.

I am sure better experts can explain it more completely, but thats the 

----- Original Message ----- 
From: "Chris LaForce" <laforcec at centurytel.net>
To: "Discussion about mythtv" <mythtv-users at mythtv.org>
Sent: Saturday, September 18, 2004 9:27 PM
Subject: Re: [mythtv-users] Remote Control Setup

> On Sat, 2004-09-18 at 18:23, Stephen Tait wrote:
>> At 17:11 18/09/2004 -0500, you wrote:
>> >Hello,
>> >    I have just been following the "Get and Install lirc" instructions
>> >from wilsonet.com and after I run the /usr/bin/irw command it just 
>> >returns
>> >back to the control prompt and the remote control does nothing.
>> >This is the output I got from /sbin/service lircd start in my
>> >  /var/log/messages file:
>> >        Sep 18 15:46:41 localhost lircd 0.7.0pre7[17919]: lircd(any) 
>> > ready
>> >        Sep 18 15:46:41 localhost lircd: lircd startup succeeded
>> >  Let me know if you have any suggestions.
>> >  Thanks,
>> >
>> >Chris.
>> If it crashes you straight back to command prompt, it usually means it's
>> looking for the wrong device - check your lird startup parameters.
>> What does ls /dev/lircd* show you? My PVR-250 remote is assigned
>> /dev/lirc/0, rather than the /dev/lircd0 LIRC is expecting. If you too 
>> have
>> the same device mappings, edit your LIRC init script and supply the 
>> device
>> in the form of:
>> -d /dev/lirc/0
>> Your distro may also allow you overrides in /etc/conf.d where you can
>> supply the same argument, and not have to worry about it being 
>> overwritten
>> on an upgrade
>> ______________________________________________________________________
> Thanks.  Now irw command sits there acting like its waiting for input
> from my remote but nothing happens when I press the buttons.  I double
> checked my connections and batties and such.  My card/remote is a
> hauppauge wintv theatre does any know which file from
> /usr/share/doc/lirc-0.7.0/remotes/ to use or what my problem might be.
> Thanks again,
> Chris.


mythtv-users mailing list
mythtv-users at mythtv.org

More information about the mythtv-users mailing list