[mythtv-users] Did MythWeb 0.16 fry anyone elses gentoo machine?

Eric Weide eric.weide at gmail.com
Thu Sep 16 11:21:48 EDT 2004

On Thu, 16 Sep 2004 15:23:22 +0100, Stephen Tait <tait at digitallaw.co.uk> wrote:
> At 12:38 16/09/2004, you wrote:
> >Op woensdag 15 september 2004 22:34, schreef Stephen Tait:
> > > Anyway, the upshot of all this is that *every single page* apache2 serves
> > > now results in a 403 forbidden, even the basic index.html. I've tried
> > > mucking around with my config files, uninstalling this hellish
> > > webapp-config thing, reinstalling apache, and it still won't go away.
> > > Obviously, permissions are all set fine, and all the error logs say is
> > > "permission denied". I can't find out what the hell is blocking everything.
> > > This is turning into the most idiotic "simple upgrade breaks apache"
> > > escapade I've ever seen!
> >
> >Well, I never got mythweb working (on a Gentoo system), oh that's not true it
> >worked on a blue monday but then some update in Apache broke it. But.. are
> >you sure that all directories that need to be traversed by Apache are
> >readable and executable by Apache? That's a thing that almost everybody hits
> >once in a while.
> Well, firstly I'd be pretty pissed off if some upgrade trod all over my
> directory permissions. Secondly, I even chmodded the entire /var/www tree
> 777 in an effort to get it to work... 403 every single time.
> There's an upgrade to apache2 just landed in portage, I'll see if that does
> anything. If not, it looks like I'm going to have to reinstall from scratch
> in order to stand a chance of maybe getting apache working again.
> And yeah, I've been using the package files in /etc/portage for quite a
> while now.
> Do any of the other gentoo users out there have the vhosts USE flag set for
> apache, or globally?
> I've also just found out that X refuses to work (blank screen, won't even
> crash back to bash) when I use the 6111 nVidia drivers to try and get
> around Myth segfaulting whenever TV stops playing. And I've got a cold. :
> sniff : I am not a happy bunny...
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
I recently installed some software that had an apache frontend.  I
haven't updated my gentoo system in awhile, and it didn't effect
mythweb, but it did install the apache files in
/usr/share/webapps/program/version/htdocs/program...so it didn't work
in apache like I thought it would.  All I did to work around it was
create a symlink to it from /var/www/localhost/htdocs/program.  You
could try that.  Let me know how it goes, I'm just waiting for some
free time so I can upgrade my backend and frontend.


More information about the mythtv-users mailing list