[mythtv-users] segfault when entering Program guide

Ivor Hewitt ivor at ivor.org
Wed Sep 15 07:21:06 EDT 2004

Kristian Eide wrote:

>>This is the same issue I had with 0.15 on Mandrake 10.0.  I didn't get
>>it resolved and havent had time to look at it further.  This was my
>>first install of Myth!
>So it could be something with using the latest version of the kernel, glibc, 
>qt or some other library, perhaps something with threading. Fun. I was hoping 
>it was something simpler, like something missing from the database, but I 
>guess it's not easy to reproduce. I'm using the tv_grab_no from XMLTV to fetch 
>program data. I tried to delete all program data manually though, and the 
>program guide still segfaulted. Is it normal for this to happen when there is 
>no program data?
>Actually, I have managed to enter the program guide without it crashing if I 
>went into the program listing view (programs by letter) first, but it still 
>crashes most of the time. It always crashes when entering from watching TV. 
>Since it has worked a few times I suspected it might be some library problem 
>or something with threading. It's strange not more people have run into this 
are you using lirc? if so, does the crash happen if you navigate using 
the navigate using the keyboard instead?

More information about the mythtv-users mailing list