[mythtv-users] MythWeather/MythMusic 0.16 Gentoo ebuilds don't work

Scott Alfter mythtv at salfter.dyndns.org
Mon Sep 13 14:41:38 EDT 2004

While getting the TV-out on my PVR350 working again (I hadn't had it working
since the motherboard in my MythTV box crapped outand I had to reinstall
from scratch), I figured I'd also upgrade MythTV to 0.16.  That part went
smoothly enough, but "ACCEPT_KEYWORDS=~x86 emerge mythmusic mythweather"
yields something like this:

Calculating dependencies ...done!
>>> emerge (1 of 2) media-plugins/mythmusic-0.16 to /
>>> md5 src_uri ;-) mythmusic-0.16.tar.bz2
>>> Unpacking source...
>>> Unpacking mythmusic-0.16.tar.bz2 to /var/tmp/portage/mythmusic-0.16/work
>>> Source unpacked.
Could not find mkspecs for your QMAKESPEC after trying:
Error processing project file:
Creating config.h, config.pro

Configuration settings:

        OpenGL support will be included
        FFTW   support will be included
        SDL    support will be included

make: *** No targets specified and no makefile found.  Stop.

!!! ERROR: media-plugins/mythmusic-0.16 failed.
!!! Function src_compile, Line 55, Exitcode 2
!!! compile problem

Changing the build order doesn't make any difference.  I noticed that the
MythTV ebuild, for some unfathomable reason, decided to build an an embedded
version of Qt instead of the normal version.  Could this have something to
do with the other MythTV components not wanting to build?

(I haven't tried building from the source tarball, as I'd rather not build
stuff outside Portage if I can avoid it.  Besides, since MythWeather and
MythMusic appear to not use autoconf/automake, I don't know how you'd get it
to build & install someplace other than /usr/local.)

 / v \ Scott Alfter
(IIGS( http://alfter.us/            Top-posting!
 \_^_/ rm -rf /bin/laden            >What's the most annoying thing on Usenet?

More information about the mythtv-users mailing list