[mythtv-users] display resolution switching still not working

John Patrick Poet john at BlueSkyTours.com
Fri Sep 10 12:24:19 EDT 2004

On Thu, 9 Sep 2004, James Armstrong wrote:
> Ok, ignore previous message from me. I wanted to be sure the switch
> resolution was working so I enabled verbose on playback. It appears it
> was still switching to the 888x508 because the video was recorded at
> 1920x1088 for some reason and I only had 1920x1080 in the setup as one
> of the alternatives. I added 1920x1088 as the second alternative and set
> it to switch to 1920x1080i.

I personally set up the "HD" resolution as the default.  In other words, set
the default resolution to 1920x1080.  Then any HD programs (1920x1088,
1280x720) use that default resolution.

Then I set alternates for non "HD".   640x480 for 640x480, 704x480 for
704x480.  For the non "HD" resolutions, I also check the "alt aspect" box to
Myth knows to display them as 4:3.

> I restarted X and it starts in 1920x1080i
> then mythfrontend starts and it changes to 888x508 and looks ok. When I
> playback the 1920x1088 show it flashes black, then the desktop shows,
> then the upper left quarter of the recording plays in the upper left
> corner of the desktop.

And the rest of the screen is the desktop wallpaper?  Doug Larrick had that
problem, but I was pretty sure that I had found a solution for it.  KDE
always worked great for me, but I would see that behavior with XFCE.  The
solution involved telling Qt the right viewport size.  Maybe your problem
has to do with the version of Qt you are running?  I am running


> On that note, maybe we can have the code that checks for the width and
> height of the video to determine the screen size to switch to do
> something like if Width is >= to set option and Height is >= set option
> then switch resolutions. That way if the video is recorded as 1920x1080
> or 1920x1088 it will switch if the setting is 1920x1080. That would
> still leave the second option open for other resolutions.

If setting 1920x1080 (or 1920x540 or 1280x720, etc) as the *default* video
res does not work for you, I will consider this.  I am also hoping that I
can squeeze more alternates onto the setup screen once the new UI is in

> Let me know what else you might need. Running FC1, XFree86  release
> 4.3.0, KDE desktop, NVidia driver 6111

I am running FC2 with it's provided xorg (although I see a new version of
xorg is available), and nVidia 6111.  I have used both KDE and XFCE with
success.  Ratpoison does *not* work.  Doug Larrick is using WindowMaker.

My only guess at this point is the version of Qt.  I can send you
instructions on exactly how I built and installed qt-x11-free-3.3.3 if you
want to give that a try.


More information about the mythtv-users mailing list