[mythtv-users] MythTV on AMD64 Gentoo

Ben Whitcher b-whitcher at northwestern.edu
Wed Sep 8 23:53:56 EDT 2004

On Wed, 2004-09-08 at 19:55, Stephen Tait wrote:
> In the meantime, can't you just use the ~x86 version? 

Do you know if Gentoo allows this?  It seems like from what I've read on
the forums, this is a bad idea for AMD64 systems.  Does anyone know how
to install 32-bit software (like ivtv) on AMD64 Gentoo?

On Wed, 2004-09-08 at 21:35, Eric Weide wrote: 
> Also, as I understand, you shouldn't use 'ACCEPT_KEYWORDS="~amd64"
> emerge mythtv'  anymore.  You should create a file,
> /etc/portage/package.keywords and fill it with the packages you want
> installed as masked (~)...
> media-tv/mythtv ~x86
> media-plugins/mythgame ~x86
> media-plugins/mythnews ~x86
> media-plugins/mythmusic ~x86
> media-plugins/mythvideo ~x86
> www-apps/mythweb ~x86
> ~amd64 in your case.  A bit off topic, but I thought I'd let you know.
>  It's mentioned in the gentoo forums quite a few times, although I
> can't seem to find it right now!

I would do this, but as soon as mythtv becomes unmasked, I plan on using 
the "stable" version.  If I edited my package.keywords file, I would be
committing my system to always upgrade to the ~amd64 (unstable) version
of mythtv.

More information about the mythtv-users mailing list