[mythtv-users] tv_grab_au and mythfilldatabase

Martin Ravell martin.ravell at rave-tech.com.au
Mon Sep 6 04:20:45 EDT 2004

I'm having some fun getting mythfilldatabase to work with the xml I pull
down from tv_grab_au and would appreciate a hand if there is anyone out
there who has gotten past the same hurdles.


The rig is 2.8GHz, Intel board, FC1, PVR350, install according to Jarod plus
X on the framebuffer. (Thankyou Daniel et al)


>From what I can gather mythfilldatabase wants to run tv_grab_au and then
suck in the generated xml, parse it and stick it in the database. Is that


I've setup tv_grab_au and have run it successfully to grab
/home/mythtv/.mythtv/Oz.xmltv. (this file now contains a bunch of what looks
to me to be valid XML)


If I try to run mythfilldatabase without any options I get:




=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2004.09.06 16:32:41


----------------- Start of XMLTV output -----------------

            tv_grab_au - (version 0.6 - release 2004-07-19)


/home/mythtv/.mythtv/Oz.xmltv:1: bad line

/home/mythtv/.mythtv/Oz.xmltv:2: bad line

/home/mythtv/.mythtv/Oz.xmltv:4: bad line



[lotsa lines removed for brevity]



/home/mythtv/.mythtv/Oz.xmltv:7139: bad line

/home/mythtv/.mythtv/Oz.xmltv:7140: bad line

/home/mythtv/.mythtv/Oz.xmltv:7141: bad line

/home/mythtv/.mythtv/Oz.xmltv:7142: bad line

No channels specified, run me with --configure

------------------ End of XMLTV output ---



This would make me think that mythfilldatabase is trying to run tv_grab_au
but is unable to reference the config that I created when I ran tv_grab_au
manually with -configure. Do I need to add something to the path or move
some config files around?



The standard Myth manual at
http://www.mythtv.org/docs/mythtv-HOWTO-9.html#ss9.1 seems to indicate that
I need to run mythfilldatabase with the -manual option which will allow me
to enter in the channel details. When I do this however I get :




/home/mythtv/.mythtv/Oz.xmltv:7141: bad line

/home/mythtv/.mythtv/Oz.xmltv:7142: bad line

No channels specified, run me with --configure

------------------ End of XMLTV output ------------------

Error in 3:1: unexpected end of file

Updating icons for sourceid: 1

Failed to fetch some program info



Which looks like the same error as above and it doesn't prompt me for diddly


Any ideas and / or a pointer to a How-To for tv_grab_au / Myth?


I'll copy my /home/mythtv/.mythtv directory to
http://www.rave-tech.com.au/mythtv/ in case this helps.





-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20040906/527c0a68/attachment.htm

More information about the mythtv-users mailing list