[mythtv-users] More FC2 MythTV problems...

1canuck2 1canuck2 at sympatico.ca
Sat Sep 4 01:39:56 EDT 2004

Replying to my own post...
One observation, when I pla back the capture mpeg from the cat /dev/video0 
command, mplayer describes it as an MPEG2 file. MythTV is doing MPEG4 
though, right? Could there be some difference thats messing stuff up here?

----- Original Message ----- 
From: "1canuck2" <1canuck2 at sympatico.ca>
To: <mythtv-users at mythtv.org>
Sent: Saturday, September 04, 2004 12:12 AM
Subject: [mythtv-users] More FC2 MythTV problems...

> So, week two of trying to get my MythTV box complete draws to a close and 
> its
> still not working...
> Here's what I have done so far:
> MythTV itself is working fine, the guide works, I can listen to music, use
> MythWeb and MythWeather, however, I still cannot watch TV.
> Some of my troubleshooting steps are outlined here:
> http://www.shspvr.com/forum/viewtopic.php?t=5668
> Summary:
> cat /dev/video0 > first_capture.mpg, then mplayer first_capture.mpg works, 
> so
> I know the PVR-250 is working.
> Many instructoins sight some variation of having to enter the command:
> modprobe ivtv-fb
> but this command fails on my machine. I get this error:
> FATAL: Error inserting ivtv_fb 
> (/lib/modules/2.6.8-1.521smp/extra/ivtv-fb.ko):
> Operation not permitted
> Other than that, everything else is good. I run Myth with a combination of
> these command in modprobe.conf:
> alias char-major-81 videodev
> alias char-major-81-0 ivtv
> and these commands in rc.local:
> modprobe i2c-core
> modprobe i2c-algo-bit
> modprobe tuner type=8
> modprobe msp3400 once=1 simpler=1 simple=0
> modprobe videodev
> modprobe saa7115
> modprobe v4l1-compat
> ivtvctl -u 0x3000
> ivtvctl -p 4
> ivtvctl -f width=720,height=480
> ivtvctl -v input=3,output=1
> When I try to Watch TV in Myth, the backend gives me this error:
> 2004-09-03 23:01:55 Changing from None to WatchingLiveTV
> Won't work with the streaming interface, falling back
> VIDOCGMBUF:: Invalid argument
> And the frontend gives me this over and over again until I kill it:
> QSocketDevice::writeBlock: Invalid socket
> 2004-09-03 23:02:13 Error writing stringlist
> Remote encoder not responding.
> I am not sure if the Myth errors are related to my inability to run the
> ivtv_fb command as I can't find much about it.
> I have checked the perms on the buffer file (ringbuf1.nuv) and buffer 
> folder
> and all is good.
> I did discover an error in mysqld startup:
> Cannot initialize InnoDB as 'innodb_data_file_path' is not set.
> and
> 040903  0:46:13  InnoDB: Out of memory in additional memory pool.
> InnoDB: InnoDB will start allocating memory from the OS.
> InnoDB: You may get better performance if you configure a bigger
> InnoDB: value in the MySQL my.cnf file for
> InnoDB: innodb_additional_mem_pool_size.
> But I fixed it by adding:
> innodb_data_file_path=ibdata1:500M:autoextend
> set-variable = innodb_additional_mem_pool_size=10M
> to the my.cnf
> I am grasping at straws here and have run out of ideas. Any help would be
> appreciated.


mythtv-users mailing list
mythtv-users at mythtv.org

More information about the mythtv-users mailing list