[mythtv-users] RE: Please help me to get my remote control working

Jack Trout witmore1 at gmail.com
Sat Oct 30 12:41:13 UTC 2004


Well I am not sure if this is the proper way to to do this, but I got
my remote working but having to modprobe the remote modules and lircd
service manually before mythtv works which is unacceptable when you
want the computer to open directly and access only with a remote, so I
added some lines to my rc.local  to launch those at startup and with
my MythFrontend starting automatically the remote is available
immediately

<begin /etc/rc.local>
#!/bin/sh
#
# This script will be executed *after* all the other init scripts.
# You can put your own initialization stuff in here if you don't
# want to do the full Sys V style init stuff.

touch /var/lock/subsys/local
/sbin/modprobe lirc_i2c ## probing for kernel module for Hauppauge Remote
/sbin/service lircd start ##starts the lircd service
/usr/bin/mtd --daemon ## added during the configuration so that
mythdvd can automatically rip dvds
<end /etc/rc.local>

I also have kde start irxevent on startup to allow for the remote
actions to be translated to my front end as my remote version doesnt
seem to be directly through mythtv without it


On Wed, 27 Oct 2004 12:07:43 +0000, Phill Edwards
<phill_edwards at hotmail.com> wrote:
> I'm so happy - I managed to get this working which means I save myself $55
> buying an Irman serial device! For anyone else teetering on the edge of
> insanity with a similar problem with their Pixelview Play TV remote, here's
> my /etc/modprobe.conf (FC equivalent of modules.conf):
> 
> alias eth0 e100
> alias snd-card-0 snd-intel8x0
> install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 &&
> /usr/sbin/alsactl restore >/dev/null 2>&1 || :
> remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
> /sbin/modprobe -r --ignore-remove snd-intel8x0
> alias usb-controller ehci-hcd
> alias usb-controller1 uhci-hcd
> # nvidia kernel module
> alias char-major-195 nvidia-1_0-6111
> # i2c
> #alias char-major-88 i2c-dev
> alias char-major-89 i2c-dev
> options i2c-core i2c_debug=1
> options i2c algo bit bit_test=1
> #bttv
> alias char-major-81 videodev
> alias char-major-81-0 bttv
> options bttv card=37 radio=0 tuner=28
> 
> Note that there are no entries for lirc_gpio - don't know why but this does
> work. You have to do a "modprobe libc_gpio" at the command line to get all
> the modules loaded.  Make sure you have copied
> /usr/share/doc/lirc-0.7.0/remotes/pixelview/lircd.conf.playtv_pro to
> /etc/lircd.conf.  Start the lircd service and then run irw - when you press
> the remote's buttons you'll see output like this:
> [root at elm etc]# irw
> 0000000061d6f807 00 vol+ pixelviewp
> 0000000061d6d02f 00 2 pixelviewp
> 0000000061d6906f 00 5 pixelviewp
> 0000000061d600ff 00 source pixelviewp
> 0000000061d600ff 00 source pixelviewp
> 0000000061d600ff 00 source pixelviewp
> 0000000061d650af 00 8 pixelview
> ...
> 
> Phew - praise be that I've got through that one!
> 
> Regards,
> Phill
> 
> 
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> 
> 
>


More information about the mythtv-users mailing list