[mythtv-users] Trouble with HD playback

John Goerzen jgoerzen at complete.org
Fri Oct 29 14:02:54 UTC 2004


I downloaded the ABC and CBS test files from wilsonet.com that were
posted here recently.  I have a pcHDTV card on order and thought they
would help me get things set up in advance of its arrival.

These are .nuv files, and I just overwrote the .nuv files for two
programs I was going to delete.  That saved me having to manually add
records to the MySQL database.

When I tried to play the files, I got no picture at all (black screen).
The sound worked fine for the first 3-5 secnods.  After that, it got
choppy.  It's not that any sound was dropped; rather, there were little
pauses inserted throughout the playback.  It was as if it alternated
between pause and playback every tenth of a second or so.

I thought at first that the problem could be an underpowered CPU.
However, top showed no process consuming large amounts of CPU time and
the CPU hovered around 50% idle.

My hard drive is running in UDMA133 mode and didn't appear to be
stressed either.

Next strange thing: if I would highlight the program in question in the
recorded programs guide, the show would start playing like usual in the
little window.  It looked like it might possibly be a little slow, but
it's hard to tell in a small window without sound.

MythTV 0.16
Athlon XP 2200+ 1.8GHz
256MB RAM, 100MB free
Samsung SP1604N hard drive
ATI Radeon 9200 video card
  XFree86 4.3.0
  ATI fglrx 3.14.1 driver
  Originally was using 640x480 resolution.  Also tried 800x600.  No
  difference.  24bpp.  Xv enabled, Xvmc disabled (I think -- I have no
    idea how to turn Xvmc on or off)
Debian sid
Sound using ALSA, AC97 onboard
Deinterlacing: tried disabling it, or using kernel

Let me know if there's any other information I can provide.

-- John

More information about the mythtv-users mailing list