[mythtv-users] lirc on Fedora Core 2 & pvr-350 failed

Michael Fenston fenston-myth at san.rr.com
Wed Oct 27 15:06:46 UTC 2004


DCL wrote:

>
> A few days ago I did a apt-get to update my Fedora Core 2 system and I 
> noticed there was a update for lirc.  Immediately after the update the 
> controler stopped working with Mythtv.  I can make it work following 
> Myth(TV)ology instructions but only to display the buttons pressed to 
> the display.  It will not work at  all with Mythtv.  The lircd is 
> stopped with "lircd dead but subsys locked" message displayed in the 
> "Service Configuration" GUI.  These are displayed in a log file:
>
> Oct 26 19:34:23 MythTV lircd 0.7.0pre8[1980]: accepted new client on 
> /dev/lircd
> Oct 26 19:34:23 MythTV kernel: lirc_dev: IR Remote Control driver 
> registered, at major 61
> Oct 26 19:34:23 MythTV lircd 0.7.0pre8[1980]: could not open /dev/lirc
> Oct 26 19:34:23 MythTV lircd 0.7.0pre8[1980]: default_init(): No such 
> device
> Oct 26 19:34:23 MythTV lircd 0.7.0pre8[1980]: caught signal
>
> This is my /etc/modprobe.conf file:
>
> alias eth0 via-rhine
> alias char-major-61 lirc_i2c
> alias snd-card-0 snd-via82xx
> install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx && 
> /usr/sbin/alsactl restore >/dev/null 2>&1 || :
> remove snd-via82xx { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; 
> /sbin/modprobe -r --ignore-remove snd-via82xx
> alias usb-controller ehci-hcd
> alias usb-controller1 uhci-hcd
> # ivtv modules setup
> alias char-major-81 videodev
> alias char-major-81-0 ivtv
> alias char-major-81-1 ivtv
> alias char-major-81-2 ivtv
> install ivtv /sbin/modprobe --ignore-install ivtv; /sbin/modprobe ivtv-fb
> install lirc_i2c /sbin/modprobe ivtv; /sbin/modprobe --ignore-install 
> lirc_i2c
> # nvidia kernel module
> alias char-major-195 nvidia-1_0-6111
>
> Any idea what caused this and what I can do to fix it?
>
> Thanks Dan
>
>
>
>
>
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>
The following is from another thread (below) ... I don't understand the 
differences between starting stuff up from modprobe.conf and modprobing 
stuff up manually in /etc/rc.d/rc.local for Fedora Core 2 .... I added 
the stuff below in my rc.local and pre8 started to work for me again (vs 
downgrading to pre7).  I also have a modprobe ivtv-fb in my rc.local 
that for some reason needs to be there for the badzzzz site X server to 
work on my PVR-350.  I think this must have something to do with the 
order modules are started up in Fedora Core 2 ... one minor change in 
some package causes this modprobe.conf to break.  I'm thinking the fix 
for this one was that lirc_i2c got loaded before ivtv in rc.local and 
that was enough to keep things happy?  Dunno.

Wondering if the better advice would be to get rid of everything 
possible in modprobe.conf and start stuff up manually in rc.local?  At 
least then all module loads would be in one place.  Anyone know the answer?

Thanks,

-Mike

Thanks for the reply. I read the thread, and placed the following commands
in /etc/rc.local instead of downgrading.
/sbin/depmod -a
/sbin/modprobe lirc_i2c
/sbin/chkconfig lircd on

It Works, but it is just a band-aid. Can someone sugest a better way to fix
it?


More information about the mythtv-users mailing list