[mythtv-users] External channel change bug on 0.16

Colin Bell colinb at gatewest.co.uk
Wed Oct 27 08:47:44 UTC 2004

It turns out that I'm such a monkey that I forgot to set the frequency 
id to the channel number for each channel. I thought that something 
like frequency would relate to a tuner and that the channel number 
would be the variable used to change channels on the external changer.

Anyway it works now. thanks to all those who gave their comments. 
Hopefully this will help someone else out there someday.

On 26 Oct 2004, at 22:49, Colin Bell wrote:

> Hi all
> I use a serial devie to change channels (red eye) on a cable box. It 
> all worked fine on 0.14 on Mandrake 9.2.
> I have now upgraded to Mandrake 10.1 and I've pretty much got 
> everything running again with Mythtv 0.16 except the external channel 
> change command. If I type it into the console with a channel number 
> (ie: /usr/bin/red_eye 120) it works fine, but even though its 
> configured in the setup it doesn't do anything. I can see the "usage: 
> device_com_port sendstring" in the logs so I know its being triggered.

More information about the mythtv-users mailing list