[mythtv-users] nuvexport problem

Andrew Plumb aplumb at gmail.com
Fri Oct 15 18:02:40 UTC 2004

On Fri, 15 Oct 2004 13:40:19 -0400, James Armstrong
<james at thearmstrongs.org> wrote:
> >Enjoy!  Now if I could just figure out how to get nuvexport to run on
> >my mythfrontend-only machine...
> >
> >Andrew.
> >
> I have nuvexport *only* running on my frontend. It is a P4 3gig HT with
> 1mega cache verses the Athlon 2000XP on the backend. I did not have any
> problems getting it installed. You do have to share and map the
> directory used by the backend for recordings on the frontend to
> /mnt/store. Nuvexport will not work unless it has access to it. It does
> not stream the files from the mythbackend, it accesses then directly on
> the share.

Hi James,

Thanks for the reply.  I suspect it's something else.  I can access my
mythtv backend machine via NFS, and I did a "ln -s /net/mythtv/video
/video" so my "/video/store" locations match.  When I run nuvexport,
it can see that I have "42 recordings", but then Perl complains about
line 32 (the include myth::recordings bit).  The file is there in
/usr/local/share/nuvexport/mythtv/recordings.pm, so it looks like the
error is only a symptom of some other problem.  Is there something I
should (not) be doing in mythtvsetup for nuvexport to work?

When I run the frontend, even from a VNC session, I'm able to browse
my recordings and see the little snippets, but as you said, nuvexport
works with NFS, not streamed files.  Does nuvexport expect a
hard-coded /mnt/store path, or is that just specific to your setup -
the equivalent on my machine is /video/store?

I've run nuvexport on the backend machine without any trouble, except
that it took 10hours to convert a 1hr recording into a 320x240 AVI I
could watch on my iRiver PMP-120.  I want to try the same on another
machine whose primary purpose will be transcoding, archiving to DVD,
and offloading to other devices like my PMP-120 or for me to access
remotely when I'm on the road.  Both machines are Epia M10K with 512MB
RAM, running Fedora Core 2.




If you don't know what to do, do something.

More information about the mythtv-users mailing list