[mythtv-users] Re: Performance really sucks here :(

Christoffer Kj°lbŠk christoffer at kjoelbaek.dk
Fri Oct 15 10:21:36 UTC 2004


fre, 2004-10-15 kl. 07:24 skrev Greg Wildman:
> On Thu, 2004-10-14 at 10:42 -0400, Micah Wedemeyer wrote:
> > About the generic VESA driver versus the Unichrome driver, there is a middle
> > ground.  I used Jarod's guide as well with FC2 and I found that it installed a
> > VIA driver that allows me to use xv.  I still get high CPU usage for most
> > things, but it is usable, at least.
> > 
> > To get it to work, just go into your xorg.conf file and add the following
> > settings:
> > 
> > Under "Modules" put:
> > 
> > Load   "via"
> > 
> > 
> > Under "Device" for the graphics adapter:
> > 
> > change Driver "vesa" to Driver  "via"
> > 
> > 
> > For me, this simple change made things run MUCH better!  It also didn't
> > require me to do any of the Unichrome stuff.  I'm still trying to get
> > Unichrome drivers to work, but I probably won't try to hard until the
> > Unichrome XvMC stuff comes out in the release version of Myth.  I heard 0.16.1
> > should have it.  Hopefully it will be here soon.
> 
> Are you running the VIA CLE266 chipset? If so have you tried Alan Cox's
> 3D DRI modules?
> 
> http://people.redhat.com/alan/
I've just tried to compile these, but I get a tons off errors, and then
it tops whit this error:
via_xvpriv.h:68: error: storage size of `pict' isn't known
via_xvpriv.h:69: error: storage size of `audio' isn't known
via_xvpriv.h:76: error: storage size of `yuv_win' isn't known
via_driver.c:256: advarsel: `int10Symbols' defined but not used
via_driver.c:331: advarsel: `MODULESETUPPROTO' declared `static' but
never defined
via_driver.c:423: advarsel: `WaitIdleCLE266' defined but not used
via_driver.c:603: advarsel: `LookupChipID' defined but not used
{standard input}: Assembler messages:
{standard input}:651: Error: symbol `from' is already defined
{standard input}:657: Error: symbol `from' is already defined
{standard input}:663: Error: symbol `from' is already defined
{standard input}:669: Error: symbol `from' is already defined
make: *** [via_driver.o] Fejl 1
[root at mythbox via]#


/Christoffer

> 
> --
> Greg
> 
> 
> 
> ______________________________________________________________________
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
-- 
~~ Christoffer Kj°lbŠk ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Email:		christoffer at kjoelbaek.dk
GnuPG / PGP:	http://kjoelbaek.dk/gnupg/kjoelbaek.asc
Homepage:	http://food4u.dk
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Dette er en digitalt underskrevet brevdel
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20041015/2db51104/attachment.pgp


More information about the mythtv-users mailing list