[mythtv-users] Re: Suse 2.6.5 lockup

Kieron Wilkinson caps at caps-project.org
Wed Oct 13 12:45:40 UTC 2004

Neil Crane wrote:
> Hi,
> After some fiddling last night, I managed to get the same problem by
> using a different XF86Config file under the 2.4 kernel (I have
> several, which I switch between according to whether I want to use the
> myth box with my TV or monitor).

Interesting. I just have one, which serves both monitor and TV.

> Maybe before you revert you could try recreating (by reprobing?) this
> file and see if it helps. If I have time over the weekend, I might see
> if I can track the problem down...

Tried that, didn't seem to have any effect.
I went back to the older 5.4 kernel, with absoltely no different in 
behaviour (frozen screen at least twice a day, no response to ssh/ping 
at all, hard reboot needed).
I also tried switching to the default nv driver, and this weekend I plan 
to try going back to the 5336 nVidia drivers since that is another thing 
I changed recently.
I tried debugging myth, but I don't get any messages, so I don't think 
it is a myth problem, just triggered by it.

It might be that our problems are different. I think I might be looking 
at a video4linux/bttv problem, especially since v4l seems to have had 
some buggy releases of late. Upgrading that is a pain, so I am hoping 
Suse will release a new kernal with a newer v4l version soon...

I'm going to try going back to mythtv 0.15 and see if I get any more 
crashes, I certainly don't remeber getting any before upgrading (but I 
upgraded a few things), maybe the newer myth triggers a bug in v4l... 
This is all speculation of course, but at this point, I have running out 
of things to try. After that, I'll try upgrading v4l... But since I have 
not compiled the kernal before, I was rather hesitant to do that.


More information about the mythtv-users mailing list