[mythtv-users] prebuffering pause using 0.16 on Mandrake v10 Asus Pundit

Henry Chin hoichin at yahoo.com
Fri Oct 8 18:31:19 UTC 2004

Here is my current setup:
Asus Pundit
Celeron 2.4G
512 Meg RAM
160 Gig HD
WiFi Card
Using SVideo out directly on board of Pundit

MythTV 0.16 (prebuilt from Thac's RPM)
ivtv (ck110)
Mandrake v10 (kernel v2.6.3)
lirc 0.7.0pre7

When I run myth (frontend & backend on same machine)
everything works fine, but when I watch live tv I get
the "prebuffering pause".  My X process runs up to 60%
CPU load and video stutter.  When I watch a
pre-recording, no problem.  Video display is smooth
and no prebuffering pause.  When I use mplayer
everything is fine as well.

I have tried a number of options:
- nicing mythfrontend (event X) to higher levels
- increase video buffer from 32 to 64 Meg in BIOS
- manual compile of MythTV (default build settings)
- made sure deinterlace functionality is turned off
- lowered resolution from 720X480 to 640X480 on ivtv
setting and in mythtv settyings.
- made sure OS is setup to use DMA and my hard disk
have DMA enabled.

Have not tried:
- getting latest sis650 driver and recompiling to see
if this makes a difference
- are there any mythtv compile options that I should
- what about OS specific compile options.  I read that
there was a problem with Debian systems with 2.4
kernels, but I think this has been solved on 2.6
- noticed (using lspci -v) that some pci devices have
conflicting interrupts.  In particular VGA IRQ is the
same as my IDE.  Cannot changing in my BIOS setting
what IRQ to use for VGA.  Not sure if this makes a

I think my problem has something to do with X taking
up 60% CPU, but I cannot figure out why this is

Do you Yahoo!?
Express yourself with Y! Messenger! Free. Download now. 

More information about the mythtv-users mailing list