[mythtv-users] mythtv dialog focus and guide problem

Michael T. Dean mtdean at thirdcontact.com
Sun Oct 3 12:12:41 EDT 2004

On 10/03/2004 09:50 AM, Donavan Stanley wrote:

>On Sun, 3 Oct 2004 09:00:12 +0300, Tomi Makinen <makinen at gmail.com> wrote:
>>I am using native lirc support with mythtv and xine. And I have thos
>>problems. ..
But the problem isn't LIRC's failing to send the keystroke to 
mythfrontend (that works fine), it's that the Myth child windows do not 
have focus, so the "current selection" isn't highlighted, and the 
keystroke goes to the wrong Myth window (the main window instead of the 
child that's above it).  For example, the JumpPoints (which cancel 
whatever is currently in progress and take you directly to a particular 
location) still work when one of the child windows without focus is on 
screen, so Myth is receiving keystrokes--just not the right Myth window.

>>I have not tried the mousemove thing tho.
>Two things can solve this:  
>1) Set your focus policy to "focus follows mouse" or
>2) Use "ratpoison" as your window manager.
That's the theory, but there's more to it.  :)

I have Fluxbox with semi-sloppy focus (and have tried sloppy focus 
(those are two versions of focus follows mouse) both with all 
combinations of "focusLastWindow" and "focusNewWindows"), and it still 
gives the partial focus problem--where only the main MythTV window 
receives focus and child windows don't (i.e. Play Recording, Delete 
Recording, "Are you sure you want to exit," and even the EPG--which 
allows you to move one space in any direction then stops accepting input 
as if each square in the EPG is a separate child window and focus isn't 
transferred properly?).  I even tried RatPoison (and TWM) and had the 
same problem.

Since moving the mouse outside of the MythTV window and back inside 
allows MythTV child windows to receive focus properly (and allows the 
main window to continue to receive focus properly), I gave up trying to 
figure it out and used the XTrap extension in a script to move the mouse 
out of, then into the window after running an external GUI app.  Note 
that this means that "focus follows mouse" is definitely set as I'm 
simply moving the mouse--not clicking it--with the script.

I'd love to find the real reason, but after about 4 hours of looking, I 
decided that it wasn't worth the effort when I can make a simple (albeit 
ugly) workaround...


More information about the mythtv-users mailing list