[mythtv-users] Audio and DSP

Tom Dombrosky tbdombrosky at gmail.com
Fri Oct 1 12:42:19 EDT 2004

On Fri, 1 Oct 2004 15:30:54 -0400, quaff at clippersoft.net
<quaff at clippersoft.net> wrote:
> OK - I upgraded from MythTV .15.1 on my gentoo box to MythTV CVS as of
> 09/30/04.
> Everything worked great - except for one thing - No sound.
> I'm using SPDIF from my intel8x0 nforce2 MB w/ ALSA and all worked fine in
> .15.1.
> Sound works with Videos, Music, using aplay, in KDE, but I cannot get sound
> to work with live tv or recordings.  I keep getting "can't connect to audio
> device".  I double checked that /dev/dsp was there and properly
> permissioned.  I've tried the various combinations of /dev/dsp, /dev/adsp,
> /dev/sound/dsp, etc...
> I see no errors in any logs or even when I start the mythbackend and
> frontend in verbose mode.
> One odd thing with ALSA is, I did do an upgrade of my kernel a day or two
> ago.  And when I boot alsa doesn't appear to start, I need to go to a
> terminal as root and do a restart of the service to get the /dev sound
> devices to appear.
> Thanks for any advice...
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

What kernel are you using?  If you have a 2.4 kernel do an "emerge
alsa-driver".  It should reinstall the correct driver.  Make sure you
have the ALSA_CARDS="intel8x0" line in your make.conf file before you
do it though.  Whenever you change kernels you have to reinstall the


More information about the mythtv-users mailing list