[mythtv-users] Samba causing Mythtv Problems

Torbjörn Jansson torbjorn.jansson at mbox200.swipnet.se
Fri Oct 1 11:54:56 EDT 2004

Is dma active on your disk(s) ?

Are you using a 2.6 kernel? If so, you may want to try adding "elevator=cfq"
to grub/lilo configuration for the kernel.
This will change the disk scheduler, it may give programs at least some
access to the disk when ther's lots of disk io going on.
The fedora fc2 kernel has this active by default.

Do you have a wierless network?

mythtv-users-bounces at mythtv.org <> wrote:
> Hey all I have an odd problem that can only be solved by shutting down
> all computers in the house and rebooting my mythtv server.
> First a little background. The mythtv server is my everthing server.
> Does samba, nfs, ntp, ftp, http, mythtv, mysql and so on.
> Mythtv is powered by a PVR-250 so the processor load is
> almost nothing.
> Server itself is a dual P2 300 machine with 512mb pc133 ram. Running
> Gentoo. 
> Ok, here is what happens.
> Everything is humming along just fine. No problems.
> Then when a machine (windows or linux) uses samba to access the server
> files (having nothing to do with mythtv) I can no longer watch mythtv.
> I get the following after a second or two.
> WriteBlock(): Aborting WriteBlock, write to socket failed!
> (just to note this is only watching shows from my frontend computers..
> the backend still records with no problems.)
> I've tried to restart samba/nfs/mysql/mythtv and even the network card
> trying to clear it. However the only thing that works is shutting down
> all computers connected to the server then starting up the server
> then all the other computers. This is a big pain.
> Any ideas on how to prevent this or at the very least, resetting
> whatever this is without rebooting the entire network.
> Thanks for taking the time to read this.
> Muddy

More information about the mythtv-users mailing list