[mythtv-users] Re: PVR-350 + PVR-250 question

Mercury Morris mercury.morris at gmail.com
Tue Nov 16 22:53:02 UTC 2004

OK, so now we know - PCI-card order makes a DIFFERENCE.

About  /dev/video16, have a look in

 /usr/share/doc/ivtv-0.1.10/modules.txt -AND-

In these two files, you will find out how to use a device
OTHER THAN /dev/video0 for output.  Specifically, how
to use a PVR-350, that is NOT /dev/video0, for output.

After I read these two files, I issued this command

 modprobe ivtv-fb ivtv_fb_card_id=1

and created /dev/video17 using Jarod's guide's example.
Then, in MythTV, under the frontend's settings -> TV Settings
-> Playback, I set the Video Device for PVR-350 to /dev/video17.
And this worked!  But, in the other parts of MythTV, mythtvsetup
to be specific, I was not successful in getting MythTV to switch
or swap /dev/video0 and /dev/video1.

I wanted to this SO badly, since only the PVR-350 has TV
comming in thru Composite0 - my satellite dish.  But MythTV
now sees the PVR-350 as /dev/video1 so when I tune the
satellite dish - I get a black screen.

Looks like I'll have to re-run mythtvsetup and answer [yes][yes]
to the two questions and start from scratch, again, for the third
or fourth time.

How about those ivtv guys!  Their code lets you designate which
device has the output capability!  But I can see how once MythTV
has set all the connections between Devices, Input Signals, etc.,
etc., it would be hard to rearrange everything.


More information about the mythtv-users mailing list