[mythtv-users] Inconsistent TV-out display

Jarod Wilson jcw at wilsonet.com
Mon Nov 15 20:15:50 UTC 2004

On Monday 15 November 2004 08:59, Joseph A. Caputo wrote:
> On Sunday 14 November 2004 00:48, Jim Eskew wrote:
> > Here is my question.
> >
> > I am using FC2 with a nVidia GeForce 4 MX 420.  I have been using
> > Jarod's guide to setup my box.
> >
> > I have s-video working, so I can see my desktop on the TV screen, but
> > when I do a test capture, the window where the video is supposed to
> > play is all green.
> >
> > At the same time, when I do a test capture, I can see the video on my
> > monitor.  Why is this happening?  I figured everything that was
> > visible on my monitor would be transferred to the tv after I got
> > S-video working.

Xv doesn't play nice in TwinView. Only one display works properly. This is 
documented in nVidia's README for their driver.

> >    Option      "MetaModes" "1024x768, 1024x768; 1024x768, 1024x768"
> This *might* be problematic... try using 800x600, as most integrated
> TV-outs won't do 1024x768.

Sounds like his display is working just fine at 1024x768. All my cards have no 
problem outputting at that resolution...

From nVidia's README:

Q: Do video overlays work across both display devices?

A: Hardware video overlays only work on the first display device.
   The current solution is that blitted video is used instead on TwinView.

Myth uses Xv video overlay, not blitted video, so there's your answer.

Jarod C. Wilson, RHCE
jcw at wilsonet.com

Got a question? Read this first...
MythTV, Fedora Core & ATrpms documentation:
MythTV Searchable Mailing List Archive
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20041115/5b244d7e/attachment.pgp

More information about the mythtv-users mailing list