[mythtv-users] Tv_grab_au 0.6 Fialing "undifined Subrouting"

Mary Wright mwright at taz-devil.dyndns.org
Sun Nov 7 08:50:02 UTC 2004


 I had lots of various troubles but most of them went away when I did a 
Mythfilldatabase --manual 

Which is like doing a tv_grab_au --configure but from within myth

After that I edited the channels as needed in the mythtvsetup 

Don't know if that helps but sound like something I had originally 

Regards Mary 

-----Original Message-----
From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of David Whyte
Sent: Sunday, 7 November 2004 5:45 PM
To: Discussion about mythtv
Subject: Re: [mythtv-users] Tv_grab_au 0.6 Fialing "undifined Subrouting"

I just ran into this same problem. Apparently, the subroutine
askQuestion has been renames and just 'ask' will do.  After doing this
it seems to work fine.

Just thought it may be useful to others to note this.


On Tue, 12 Oct 2004 13:01:18 +0800, Hendo Nominees
<jchendo at westnet.com.au> wrote:
> Firstly thanks to all the ppl out there who help on the list, cos
> this is a great product.
> Now i have searched the archive and googled for tv_grab_au an found
> varsious similar issues but the resolves in them have not helped in
> this case.
> The problem i am having is while following Jarods guide (btw thanks
> Jarod for that its great to have something like that to follow ) i
> get upto using the mythtvsetup and i run into the TV_GRAB_AU problem.
> there is no tv_grab_au in the default .16 install. off to the list,
> find the link to teh tv_grab_au at onlinetractorparts and then
> install the compnents in the various places.
> great.
> run setup and when it tries to find the channels nothing. (it does
> not 'hang ' it actualy says sorry carnt find.) so i know to alt tab
> into the terminal window and set up the channels etc but i get the
> following errror.
> ----- SNIP------
> [root at myth_boxen mythtv]# mythtvsetup
> Would you like to clear all capture card
> settings before starting configuration? [no]  y
> Would you like to clear all program/channel
> settings before starting configuration? [no]  y
> mythtv: could not connect to socket
> mythtv: No such file or directory
> lirc_init failed for mythtv, see preceding messages
> 2004-10-12 11:38:58 Please wait while MythTV retrieves the list of
> available channels
>         tv_grab_au - (version 0.6 - release 2004-07-19)
> Undefined subroutine &main::askQuestion called at /usr/bin/tv_grab_au
> line 487.
> 2004-10-12 11:39:00 tv_grab_au --config-file
> '/root/.mythtv/fta-antenna.xmltv' --configure
> 2004-10-12 11:39:00 exited with status 6400
> If this is the master backend server:
> Now, please run 'mythfilldatabase' to populate the database
> with channel information.
> [root at myth_boxen mythtv]# mythfilldatabase
> ----------------- Start of XMLTV output -----------------
>         tv_grab_au - (version 0.6 - release 2004-07-19)
> config file /root/.mythtv/fta-antenna.xmltv is empty, please delete
> and run me with --configure
> ------------------ End of XMLTV output ------------------
> Error in 3:1: unexpected end of file
> Updating icons for sourceid: 1
> Failed to fetch some program info
> [root at myth_boxen mythtv]# tv_grab_au --configure
>         tv_grab_au - (version 0.6 - release 2004-07-19)
> using config filename /root/.xmltv/tv_grab_au.conf
> The configuration file /root/.xmltv/tv_grab_au.conf
> already exists.  There is currently no support for altering an
> existing configuration: you have to reconfigure from scratch.
> Do you wish to overwrite the old configuration? [yes,no (default=no)]
> y
> Undefined subroutine &main::askQuestion called at /usr/bin/tv_grab_au
> line 487, <STDIN> line 1.
> [root at myth_boxen mythtv]#
> ----SNIP-----
> i then tried to go back to teh 2.0 version of the graber with little
> succsess.
> googleing and searching the archive found only one thing that sortof
> matched my problem
> http://www.gossamer-threads.com/lists/mythtv/users/82750?search_string
> =tv_grab_au;#82750
> go down to post 3 and there ihe walks a person though his problem but
> when i try i  get the same error.
> could someone lend me there brain please?
>  the boxen is a P3 1ghz
> 512 ram
> 20 gig maindrive
> 80 gig video drive (as per guide)
> winfast tv2000 tv card (hard to get working but its cheap untill the
> Wife Approval Factor goes up and i can buy a PVRx50 or the MCE
> version therof (anything else is hard to ge in AUS and or very
> expensive))
> mx440 tv out
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

GMAIL is 'da bomb baby....YEAH

More information about the mythtv-users mailing list