[mythtv-users] Please help with Avermedia DVB-T 771

Jan Dölle myth at jan-doelle.de
Fri Nov 5 13:09:45 UTC 2004

Am Freitag, 5. November 2004 11:00 schrieb Tate Needham:
> I have been trying to get the Avermedia DVB-T 771 going and not having much success. I have the version that has an mt352 frontend.
> I tried using the DVB drivers that are in 2.6.10rc1 of the kernel, but i keep getting a segfault when I try and load the mt352 driver.
> Can someone point me to versions of drivers that are known to work please? I am at a loss as to how to get this card going.
> Thanks,
> Tate.
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users


I run in to the same problem with 2.6.10rc1 in case I do not load dvd_bt8xx before mt352

Also take care that the firmware 'sc_main.mc' (find on windows driver cd) is placed in /usr/lib/hotplug/firmware/ 

And at least make sure that /dev/dvb/adapter0-3 is existing. If not you can use the MAKEDEV-DVB.sh script to create it.

modprobe bttv
modprobe bt878
modprobe dvb_core
modprobe dvb_bt8xx   <--- Must Load before mt352!!!
modprobe mt352

The follow links will help to manage the myth stuff:


But I run in to a other situation: After a while capturing , I will get in kern.log (syslog):
Nov  4 23:22:40 localhost kernel: bt878(0): irq FBUS risc_pc=1eb161b8
Nov  4 23:22:40 localhost kernel: bt878(0): irq FBUS risc_pc=1eb161e8
Nov  4 23:22:40 localhost kernel: bt878(0): irq FBUS risc_pc=1eb16208
Nov  4 23:22:40 localhost kernel: bt878(0): irq FBUS risc_pc=1eb16210
Nov  4 23:22:40 localhost kernel: bt878(0): IRQ lockup, cleared int mask

After this will happend the card will not long work until I reboot.

Anyone an Idea

Cheers Jan

More information about the mythtv-users mailing list