[mythtv-users] ALSA Volume Control

Matthew Gleed mgleed at gleed.us
Fri Nov 5 05:06:28 UTC 2004

      On 11/04/2004 06:19 PM, Matthew Gleed wrote:

     > I'm having a problem with not being able to adjust the volume within
     > Mythfrontend using ALSA. I've been going over the archives and I've
     > seen a couple references to this problem without any resolution
     > posted. When ever I try to adjust the volume I see the OSD come up
     > but it is always at 0 percent. My audio output is fine as are the
     > audio levels and I'm able to adjust the volume levels within
     > alsamixer. I'm using the audio on my motherboard which is
    provided by
     > an intel ICH5 chipset.

    What audio code are you running? version .16, CVS, or Ed's latest

     > I think I'm pretty clear on how to configure the audio output device
     > field. However, I haven't found any documentation that was clear on
     > what should be used in the mixer device field.

    The mixer field should be "default" (without the quotes) if you are
    using the "big audio update" patch.

     > So I have just assumed that the two fields should be configured the
     > same. If this isn't accurate can someone set me straight. If anyone
     > has any ideas as to why I cannot adjust the volume levels within the
     > frontend I would appreciate it. Do I need any of the ALSA plugins to
     > be able to adjust volume? Thanks!

    Myth doesn't support changing the volume with ALSA yet unless you are
    using the "big audio update" patch. If you are using the audio patch, I
    have noticed that I can't change the volume using the optical out with
    my ICH4 mobo. Not sure about the ICH5. I just bought an ICH5 mobo with
    coax S/PDIF output so I'll let you know how that goes. Anyway the only
    way I could get the volume control to work on the ICH4 was to use the 6
    channel analog out to my receiver.

    Also there is a problem with the latest audio patch where the volume
    control can get stuck on a certain volume because the
    increment/decrement amount is less than the smallest range adjustment
    (if you don't understand what this means just take my word for it).

    I just sent a patch against Ed's latest patch to the dev list which
    improves Alsa support and should fix the volume control. I am
    rebuilding my dev machine right now so I can't actually test the
    but the audio works much better (no more audio lag).


Thanks for the reply David.  So many details, I always leave out 
something.  I'm running CVS as of 11/4/04.  So your saying that the 
mixer should be set to "default" or "ALSA:default".  I tried is both 
ways didn't make a difference.  I tried centering the main and pcm 
volumes in alsamixer to see if that would help unstick them due to the 
increment issue you mentioned above.  That didn't help either.  The 
volume OSD is always 0 and unresponsive.  Would I need any special 
directives in the .asoundrc file or should the defaults work?

I'll look forward to your patch being rolled up in to CVS.  Sure wish I 
could code, but I'm just a lowly network engineer.  ;)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20041105/d6de930f/attachment-0001.htm

More information about the mythtv-users mailing list