[mythtv-users] Alsa volume control

Matthew Gleed mgleed at gleed.us
Thu Nov 4 23:19:12 UTC 2004

I'm having a problem with not being able to adjust the volume within 
Mythfrontend using ALSA.  I've been going over the archives and I've 
seen a couple references to this problem without any resolution posted.  
When ever I try to adjust the volume I see the OSD come up but it is 
always at 0 percent.  My audio output is fine as are the audio levels 
and I'm able to adjust the volume levels within alsamixer.  I'm using 
the audio on my motherboard which is provided by an intel ICH5 chipset.

I've tried using a very simple .asoundrc file such as:

pcm.intel8x0 {
        type hw
        card 0

ctl.intel8x0 {
        type hw
        card 0

and using ALSA:intel8x0 in both audio output and mixer device in the 
frontend audio config screen.  I've also tried using no .asoundrc file 
and ALSA:default.

I think I'm pretty clear on how to configure the audio output device 
field.  However, I haven't found any documentation that was clear on 
what should be used in the mixer device field.  So I have just assumed 
that the two fields should be configured the same.  If this isn't 
accurate can someone set me straight.  If anyone has any ideas as to why 
I cannot adjust the volume levels within the frontend I would appreciate 
it.  Do I need any of the ALSA plugins to be able to adjust volume?  Thanks!


More information about the mythtv-users mailing list