[mythtv-users] Nova-T and system hangs

Peter Guthrie peter at unixplanet.co.uk
Wed Nov 3 11:22:42 UTC 2004


Generic Motherboard with KT266A chipset
Duron 750Mhz, 512MB DDR RAM
Hauppauge Nova-T tuner
Fedora Core 2 (2.6.8 kernel) with MythTV 0.16 (built with Jarods guide
and Atrpms).


Until yesterday the system had an analog WinTV PCI tuner card. As you
can imagine with that CPU the performance and picture quality was not
good but it worked ok.

Last night I removed the analog tv card and replaced it with the Nova-T
and followed the guide at http://www.ethics-gradient.net/myth/mythdvb.html.

Following that procedure I had some success in viewing digital tv
outside of Myth with dvbstream and mplayer although it initially
complained about opening a sound device (fixed by using the '-ao alsa'
option with mplayer) and would stall after about 5 seconds. I enabled
'PCI delay transaction' in the BIOS as suggested in the above guide but
it seemed to make no difference.

Undeterred I decided to bash on and set up the card in Myth. With just
one channel configured I was able to start the frontend and view that
channel for about 60 seconds before it locked up the the whole system
hard. In subsequent attempts (after a power reset and fsck) the system
now locks up instantantly when I select the 'Watch TV' menu item in the

I know it's not much to go on but does anyone have any ideas what I
might try to debug this? I can't see any messages that may help me
understand why it's locking up as I can't switch to any VC's once it's
locked up. tzap works fine and I get the FE_LOCK flag almost instantly
outside of Myth so I think the signal is fine (certainly the picture
looked incredible for the 60 seconds or so I saw it ;)


More information about the mythtv-users mailing list