[mythtv-users] Problem with Jarod's guide, a PVR350 & 250, mplayer, & X

Paul Kidwell tmb at ieee.org
Thu May 27 13:51:44 EDT 2004

Hi Everybody

I'm using Jarod's guide to do an install on a FC1 machine. I have an
ASUS MB with an onboard AD1980 for sound (which I actually got working
just last night :) I also have a PVR350 for video in and out. (Had a
PVR250 in as well but that was giving me lockup problems when I loaded
ivtv, so I thought I'd at least get a single capture board up and
running first, then add the '250 later)

I got to chapter 11 in the guide. Up to the point where you actually
capture some video. At a root prompt I typed in:

cat /dev/video0 > /tmp/test_capture.mpg

I let it run for a few seconds, then hit <ctrl>-c to stop it. The guide
then says "Use that copy of mplayer you installed a bit ago to view the
capture." I don't seem to recall installing it in the guide. In fact,
doing a search of the printer friendly version of the HOWTO shows that
line to be the first occurrence of the word "mplayer". In any event, at
a root prompt I then typed:

mplayer /tmp/test_capture.mpg

Just like the HOWTO says and got:

> [root at localhost mythtv]# mplayer /tmp/test_capture.mpg
> mplayer: error while loading shared libraries: libxvidcore.so.4:
> cannot open shared object file: No such file or directory
> [root at localhost mythtv]#
> [root at localhost mythtv]#

The capture file was about 7 meg, so I loaded up Samba so I could share
the drive across my network and transfer it to another machine. I did
that and was able to use WMP to view the capture and see that it worked
(yeaaaaa! :)

I went back to my MythTV box and went looking for mplayer. I found it
(don't remember the directory) but even trying to execute it after
cd'ing to that directory didn't help.

Any thoughts on this???

I pressed on anyway. Got through the part where you're taking live video
in and sending it out to your TV (which also worked... yeaaaa!!! :)

The next step was to run X on the PVR-350s TV out. I grabbed Jarod's
XF86Config-PVR350.txt. Backed up the original (good thing) and copied it
over to XF86Config. Edited it for my  I hit <ctrl><alt><backspace> and
my vga monitor shut down and I got a login screen on my TV... Sorta...
It looked like what you get when you try watching a SVGA signal on an
old standard VGA monitor.

At this point the HOWTO says "... you probably did something wrong, so
retrace your steps. =)"


I seem to recall that Jarod said somewhere in his guide that he's
running on a HDTV so the settings in his config file might be for that.
I'll be tearing into this one a bit more tonight, but it was about
1:30AM when this cropped up and my alarm is set for 6:00 :)

Again any suggestions would be appreciated.


More information about the mythtv-users mailing list