[mythtv-users] compile error on 0.15?

Jason Krohn myth at jkrohn.com
Thu May 27 00:00:46 EDT 2004

I had this problem with CVS and fixed it by doing one of two things.  
Unfortunately I did both of these at once so I don't know which fixed it :)
1) Edited config.mak and changed -O3 to -O2
2) Edited settings.pro and changed -O3 to -O1

After a make clean, everything compiled great for me.


malcolms wrote:

>I'm getting this when I try and compile 0.15.  Anyone know what it means?
>gcc -c -pipe -w -Wall -g -O3 -DPIC -fPIC -fomit-frame-pointer 
>-DQT_SHARED -I/usr/lib/qt3/mkspecs/default -I. -I../.. 
>-I/usr/lib/qt3//include -o ffv1.o ffv1.c
>ffv1.c: In function `encode_rgb_frame':
>ffv1.c:465: internal compiler error: in find_function_data, at function.c:329
>Please submit a full bug report,
>with preprocessed source if appropriate.
>See <URL:https://qa.mandrakesoft.com/> for instructions.
>make[2]: *** [ffv1.o] Error 1
>make[2]: Leaving directory 
>make[1]: *** [sub-libavcodec] Error 2
>make[1]: Leaving directory `/home/malcolm/mythtv0.15/mythtv-0.15/libs'
>make: *** [sub-libs] Error 2
>mythtv-users mailing list
>mythtv-users at mythtv.org

More information about the mythtv-users mailing list