[mythtv-users] MythMusic Getting CD Track Info From Freedb Or CDDB?

KianTeck chua_kianteck at yahoo.co.uk
Sun May 16 11:12:03 EDT 2004

Additional information:

I stopped mythtv and restarted it from a shell.  Then got into 
MythMusic.  When I inserted a CD into the drive, this is what I got:

----------------------------------- Snip 
databasebox.o: Couldn't find your CD. It may not be in the freedb database.
               More likely, however, is that you need to delete  ~/.cddb and
               ~/.cdserverrc and restart mythmusic. Have a nice day.
----------------------------------- Snip 

I did as what the above suggested, but still no  luck.  The above files 
are being recreated.

So, what's gone wrong?  Please help.


KianTeck wrote:

> OK, so is it getting from freedb or cddb(gracenote)?
> I've tried to insert my collection of audio CDs into my DVD/CD-RW 
> drive, however, it's not able to recognise any of them.  It's still 
> able to play them though.   A check with netstat -n shows that my 
> mythtv box attempts to connect to some external IP 
> hosts(,,,  
> But after initial connection being "ESTABLISHED", the connection gets 
> dropped (ie it changes to "CLOSE_WAIT").
> I've confirmed that my Linux based firewall (another box) protecting 
> my home LAN has port 8880 opened.  I've my work laptop (Mandrake 9.2) 
> with KsCD installed and is able to retrieve the CD information when 
> connected to my home LAN.
> What can I do or where can I check to fix this problem with MythMusic?
> Thanks
> Kian Teck

More information about the mythtv-users mailing list