[mythtv-users] PVR-250, no signal

Kevin D. Snodgrass kds.mythtv at cox.net
Tue May 4 22:09:05 EDT 2004

Following Jarod's howto...

Everything appears fine, but I get no capture with cat 
/dev/video0 > test1.mpg.  I tried /usr/bin/test_ioctl -p 
[012345678], and only -p 4 gives many anything but a totally 
blank picture.  With -p 4 I get static.  Same thing when 
done as user mythtv or root.  Trying to capture from coax on 
a regular US cable connection.

Also, when I run ptune.pl (as root) I get a segfault.
#/usr/lib/ivtv/ptune.pl --channel 8
Ch.8: 181250 2900
Segmentation fault

Here is the lspci -v, dmesg anc /proc/interrupts output 
(edited to remove lots of extraneous stuff).  Notice this is 
a CX23416 chip.

#lspci -v

01:0a.0 Multimedia video controller: Internext Compression 
Inc iTVC16 (CX23416) MPEG-2 Encoder (rev 01)
	Subsystem: Hauppauge computer works Inc. WinTV PVR 250
	Flags: bus master, medium devsel, latency 64, IRQ 5
	Memory at d4000000 (32-bit, prefetchable) [size=64M]
	Capabilities: [44] Power Management version 2

Linux version 2.4.22-1.2179.nptl_47.rhfc1.at 
(bachbuilder at heretic.physik.fu-berlin.de) (gcc version 3.2.3 
20030422 (Red Hat Linux 3.2.3-6)) #1 Sat Apr 17 09:22:02 EDT 
i2c-core.o: i2c core module version 2.8.4 (20040207)
i2c-core.o: i2c core module version 2.8.4 (20040207)
i2c-core.o: i2c core module version 2.8.4 (20040207)
Linux video capture interface: v1.00
ivtv: version 0.1.9 (release) loading
ivtv: SGarray_size = 320, DSGarray_size = 16
ivtv: Found an iTVC16 based chip
ivtv: Unreasonably low latency timer, setting to 64 (was 32)
tuner: chip found @ 0xc2
tuner(bttv): type forced to 2 (Philips NTSC (FI1236,FM1236 
and compatibles)) [insmod]
saa7114.c: starting probe for adapter ivtv i2c driver #0 
saa7114.c: detecting saa7114 client on address 0x42
saa7115.c: writing init values
status: (1E) 0x48, (1F) 0xc0
msp34xx: init: chip=MSP3448W-A2, has NICAM support
msp3410: daemon started
ivtv: Encoder revision: 0x02040011
ivtv: Registered v4l2 device, minor 0
ivtv: Registered v4l2 device, minor 32
ivtv: Registered v4l2 device, minor 224
ivtv: loaded

#cat /proc/interrupts
   0:    1317878          XT-PIC  timer
   1:       9790          XT-PIC  keyboard
   2:          0          XT-PIC  cascade
   3:       1676          XT-PIC  usb-ohci, NVidia nForce2
   5:       3031          XT-PIC  usb-ohci, ivtv: iTVC15/16 
mpg2 encoder chip
   8:          1          XT-PIC  rtc
  10:     956802          XT-PIC  ehci_hcd, nvidia
  11:      54012          XT-PIC  eth0
  12:       7190          XT-PIC  PS/2 Mouse
  14:      58605          XT-PIC  ide0
  15:     222372          XT-PIC  ide1
NMI:          0
ERR:          0

Could there be a problem with ivtv and usb-ohci using the 
same IRQ?  How can I force a PVR-250 to use a different IRQ?

More information about the mythtv-users mailing list