[mythtv-users] Help with install

Ryan mythtv at frouse3.homelinux.com
Wed Mar 31 13:18:48 EST 2004

I had a similar issue the first time i attempted to install mythtv. I
added the following to root's .bash_profile and it corrected the issue:

export LD_ASSUME_KERNEL=2.2.5

Also, I've scripted Jarod's install for FC1 and it can be found at
http://frouse3.homelinux.com/forum.  It is a perl based script that walks
step by step through the script. I just built a new a machine about 2
weeks and it worked fine for me.


> I need help with my installation:
> I'm using the following guide http://wilsonet.com/mythtv/fcmyth.php the
> problem I am having is early on in the installation process. After
> running the following command from section 6:
> # apt-get update && apt-get dist-upgrade
> it seems to update fine without any problems. When I go to the next step
> which is editing the sources.list and doing another update:
> # apt-get update
> I get the following error"
> error: cannot open Packages database in /var/lib/rpm
> E: could not open RPM database
> I then try the following suggestion:
> After the big upgrade, you MAY get an error about being unable to open
> the rpm database (this used to happen to me w/RHL9, but hasn't ever with
> FC). If you do encounter this error, try the following:
> # rm -f /var/lib/rpm/__db*
> # rpm -vv --rebuilddb
> After trying this I still get the same error when trying to #apt- get
> (anything)
> Please assist.

More information about the mythtv-users mailing list