[mythtv-users] lirc fails to start on bootup but works when run manually

homebreweverything homebreweverything at myway.com
Tue Mar 30 10:09:17 EST 2004

It's working because it contains a race condition. If mythbackend loads before lircd, it will work. If you reverse them, it will not. My modified modules.conf removes this race condition. It will properly load drivers as needed, regardless of when mythbackend or lircd is loaded, since lirc_i2c is labelled as being dependant on ivtv. I think my modules.conf will work for more people because of this, with less startup script changes, and in situations where maybe mythbackend shouldn't be loaded at all.


--- On Tue 03/30, Jarod Wilson < jcw at wilsonet.com > wrote:
From: Jarod Wilson [mailto: jcw at wilsonet.com]
To: mythtv-users at mythtv.org, homebreweverything at myway.com
Date: Mon, 29 Mar 2004 21:12:50 -0800
Subject: Re: [mythtv-users] lirc fails to start on bootup but works when run manually

On Mar 29, 2004, at 11:38, homebreweverything wrote:<br><br>> I figured it out. I turned on modprobe logging to track down what was <br>> loading and when during the reboot. I had tried modprobe lirc_i2c <br>> before running lircd, but since the modules.conf I was using had no <br>> dependancies for lirc_i2c, it loaded lirc_i2c without loading ivtv, <br>> thus, it did not work.<br>><br>> I then tested modprobe ivtv before running lircd, which loaded ivtv, <br>> and due to the modules.conf _started_ to load lirc_i2c, and lirc_dev, <br>> but it shows only as (Initializing) in the log, not that it's fully <br>> loaded. My theory is if you use "add aboe ivtv lirc_dev" in <br>> modules.conf, and then modprobe ivtv, when modprobe exits, the <br>> lirc_dev module is only in the process of being installed, and running <br>> lircd immediately after it will yeild a failure. I only tested this <br>> by putting a modprobe ivtv, then modprobe lirc_i2c infort of running <br>> lircd, and it worked. A better test of this theory would be to probe <br>> ivtv, then sleep for some time... or ask someone that knows more <br>> about it than me :)<br>><br>> After determining that, I made lirc_i2c dependant on ivtv with "add <br>> below lirc_i2c ivtv" replacing "add above ivtv lirc_dev lirc_i2c" in <br>> my modules.conf. Now I don't have any modprobes in any of my startup <br>> scripts. When lircd loads, it modprobes everything correctly. I'd <br>> think this would be the correct dependancy setup for modules.conf. <br>> Anyone have any comments? Is this an improvement, luck, worse, or am <br>> I missing something?<br><br>Here's the relevant sections from my modules.conf, which works peachy <br>for me (and many others), no modprobes anywhere:<br><br># lirc<br>alias char-major-61 lirc_i2c<br># ivtv<br>alias char-major-81 videodev<br>alias char-major-81-0 ivtv<br>alias char-major-81-1 ivtv<br>options ivtv mpg_buffers=90<br>options tuner type=2<br>options msp3400 once=1 simple=1<br>add below ivtv msp3400 saa7115 tuner<br>add above ivtv lir
c_dev lirc_i2c<br><br>My lircd init script is the third one that runs after the mythbackend <br>init (S86 and S90). No clue why your setup wasn't working though... :-\<br><br>-- <br>Jarod C. Wilson, RHCE<br><br>Got a question? Read this first...<br> http://catb.org/~esr/faqs/smart-questions.html<br>MythTV, Fedora Core & ATrpms documentation:<br> http://wilsonet.com/mythtv/<br>MythTV Searchable Mailing List Archive<br> http://www.gossamer-threads.com/archive/MythTV_C2/<br>Attachment: PGP.sig (0.19KB)<br>

No banners. No pop-ups. No kidding.
Introducing My Way - http://www.myway.com

More information about the mythtv-users mailing list