[mythtv-users] ME6000, PVR350, Myth(TV)ology, /dev/video0 I/O error

Scott Francis scott.francis at newisys.com
Tue Mar 30 09:32:31 EST 2004

Make sure you do a chmod on the /dev/video files so that myth or any other nonroot account can see it.  I'd do a 

chmod 755 /dev/video* 

Or something like that.


-----Original Message-----
From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org]On Behalf Of bishop
Sent: Monday, March 29, 2004 8:35 PM
To: MythTV List
Subject: [mythtv-users] ME6000, PVR350, Myth(TV)ology, /dev/video0 I/O

I'm at my wits' end, almost.  I've followed every word of Jarod's 
instructions to the letter, and I just don't have enough knowledge about 
the situation to have any freakin' clue in the matter.

Jarod says:
> # cat /dev/video0 > /tmp/test_capture.mpg
> (ctrl-c to stop capture)

and my machine says:
> [root at otnemem root]# cat /dev/video0 > /tmp/test_capture.mpg
> cat: /dev/video0: Input/output error

No problem, Jarod says:
> If you get the following error:
> cat: /dev/video0: Input/output error
> Run the following commands to reload the driver (this won't work for PVR-350 users if the ivtv-fb module is loaded -- see above):
> # /sbin/rmmod ivtv
> # /sbin/modprobe ivtv
> Now try the capture again.

Yet, my machine says:
> [root at otnemem root]# /sbin/rmmod ivtv
> [root at otnemem root]# /sbin/modprobe ivtv
> [root at otnemem root]# cat /dev/video0 > /tmp/test_capture.mpg
> cat: /dev/video0: Input/output error

All this stuff is entirely new, purchased after my KT133-based system 
seemed to suffer from typical DMA problems and I replaced that 
overpriced 'silent' (ha!) Overture case and most of the stuff in it. 
The OS install is new and clean.  I'll post like a million config file 
details if you want, but I've done it before today's 100% 
paint-by-numbers install.

I think I need some encouragement to even continue to try, actually, as 
I'm nearly in a state of mind that would result in my shiny new ME6000 
unit being reduced into a pile of very small bits and lit on fire, 
around which I'll be dancing like a navajo.  Judging by the traffic on 
this list, there must be a million people on it.  There's gotta be one 
guy who's successfully set up FC1 Myth on an ME6000 and a PVR350, one 
guy who knows maybe what the hell I'm doing wrong.

Anyone spare a clue?  Whaddaya wanna know first?  Please CC any replies 
to me as well.  Hell, call me collect if you want.  I don't want to miss 
my salvation in this flood, and I'm thinking the apparent FAQness of my 
question will only induce the square root of one reply.

  - bish

16 Storeys = 1/2 * 9.8 * t^2 , regardless as to weight of MythTV unit.


More information about the mythtv-users mailing list