[mythtv-users] 0.14 + VIA M1k + UDMA6 + full duplex = prebufferingpause

Mikhail D'Vane mikhaildvane at hotmail.com
Thu Mar 25 21:34:22 EST 2004

You probably have a stepping 3 of the Nehemiah processor.  This processor
(or perhaps the kernel support for it) does not report mmx capabilities

One of the directories in /proc will tell you your CPU stepping.  (Sorry, 
in front of any linux machine right now, so I can remember exact directory -
it's name is pretty obvious.)

If you have a stepping 3, you need to hard code the edx return value in
the cputest.c file and recompile mythtv (or maybe just mythfrontend).  You
can find the exact information on what to add to the cputest.c file if you
search the archive for posts by me with "cputest.c" in them.

(cputest.c is in the myth source code.  If you go to the top level directory
where you unpacked mythtv, just do "find -name cputest.c" to get the

Hope this is your problem - I puzzled over it for *months* before stumbling
onto the solution (Google is your friend - try "edx cputest.c epia" and 
find the info I did.)


>From: "Scott Rowe" <mythgnomer at rowelab.com>
>Reply-To: Discussion about mythtv <mythtv-users at mythtv.org>
>To: "'Discussion about mythtv'" <mythtv-users at mythtv.org>
>Subject: [mythtv-users] 0.14 + VIA M1k + UDMA6 + full duplex = 
>Date: Thu, 25 Mar 2004 18:16:34 -0600
>Okay, I have a very frustrating situation..
>So I'm building my third m1k mythfrontend, with corsair DMA266 memory,
>Maxtor 80GB Ultra ATA/133 HD, Memorex DVD-+r/-+rw, and RH9.
>I used the VIA binary driver (latest clexf*_lite- ~420-500 fps in 
>alsa (both 1.0.3 and 0.9.6), via rhine driver (compiled myself, verified
>full duplex 100mb link with mii-tool). Stock Xfree 4.3.0.
>Hdparm -I shows udma6, so that's better than my other m1k boards. I've 
>setting that to udma5, and I've also tried underclocking the RAM back
>(multiple settings, same result).
>DVDs play beautifully (mplayer and ogle), mplayer plays avis, mpg files, 
>with multiple display methods (-vo xv, sdl) perfectly. Mythmusic works
>flawlessly as well (192kbps MP3)..
>I've tried two versions of alsa, as well as the viaaudiocombo, and
>I've tried different memory (pulled from a working m1k,) pulled out the 
>Bios is the latest version (1.13 out of the box). MTRR shows only two
>registers after the 'echo' fix added to /etc/rc.local.
>But live TV and recorded shows have horrible pauses.
>Searching for 'prebuffering pause' in the archives seems to turn up fixes
>involving networking, DMA, MTRR, audio drivers, and video drivers.
>Even enabling 'extra audio buffering' only helps a little bit. Using
>anything other than alsa makes the situation worse.
>By every standard that I know how to check, this machine should scream as a
>frontend. Anyone have any other areas that I might check? I'm building this
>for a friend who's on the road right now, so I have some time before he 
>the box home. I'm hoping that someone will have something that I can 
>to try to figure out why this isn't working.
>-Scott Rowe
>mythtv-users mailing list
>mythtv-users at mythtv.org

All the action. All the drama. Get NCAA hoops coverage at MSN Sports by 
ESPN. http://msn.espn.go.com/index.html?partnersite=espn

More information about the mythtv-users mailing list