[mythtv-users] 0.14 + VIA M1k + UDMA6 + full duplex = prebuffering pause

Scott Rowe mythgnomer at rowelab.com
Thu Mar 25 19:16:34 EST 2004

Okay, I have a very frustrating situation..

So I'm building my third m1k mythfrontend, with corsair DMA266 memory,
Maxtor 80GB Ultra ATA/133 HD, Memorex DVD-+r/-+rw, and RH9. 

I used the VIA binary driver (latest clexf*_lite- ~420-500 fps in glxgears),
alsa (both 1.0.3 and 0.9.6), via rhine driver (compiled myself, verified
full duplex 100mb link with mii-tool). Stock Xfree 4.3.0. 

Hdparm -I shows udma6, so that's better than my other m1k boards. I've tried
setting that to udma5, and I've also tried underclocking the RAM back
(multiple settings, same result). 

DVDs play beautifully (mplayer and ogle), mplayer plays avis, mpg files, etc
with multiple display methods (-vo xv, sdl) perfectly. Mythmusic works
flawlessly as well (192kbps MP3)..

I've tried two versions of alsa, as well as the viaaudiocombo, and

I've tried different memory (pulled from a working m1k,) pulled out the DVD.
Bios is the latest version (1.13 out of the box). MTRR shows only two
registers after the 'echo' fix added to /etc/rc.local. 

But live TV and recorded shows have horrible pauses. 

Searching for 'prebuffering pause' in the archives seems to turn up fixes
involving networking, DMA, MTRR, audio drivers, and video drivers. 

Even enabling 'extra audio buffering' only helps a little bit. Using
anything other than alsa makes the situation worse.

By every standard that I know how to check, this machine should scream as a
frontend. Anyone have any other areas that I might check? I'm building this
for a friend who's on the road right now, so I have some time before he gets
the box home. I'm hoping that someone will have something that I can explore
to try to figure out why this isn't working. 

-Scott Rowe

More information about the mythtv-users mailing list